Ga door naar hoofdinhoud

Announced on October 16, 2014, identifiable by the model number A1347 and EMC 2840.

197 Vragen Bekijk alle

SSD not recognized on boot by system

Hello community,

After days of tests and readings, I turn to you to seek for advice.

Here is my problem:

I am trying to upgrade a new Mac Mini (Late 2014 model) from it's original mechanical HDD to a Vertex 2 SSD I have been using for a few years with no problems to report, great product.

First 1 cloned my HDD onto the Vertex 2 SSD using SuperDuper, all went well.

I then switched disks and set the SSD in the SATA III slot inside the Mac Mini and reboot... the disk would boot, the recovery system and the disk utility would not see the disk (or it would see it just long enough to try to make a disk verification and then would disappear).

Here is what I have already tried:

- Boot from Linux LiveCD, I can see the Vertex SSD, I can see all it's file and browse them

- Reformat the disk, in HFS+ with GUID partition table

- Clean PRAM

- Perform a Hardware Check - all good

- Boot from the original HDD connected through a SATA-to-USB adapter - all good, i can boot the system, but i don't see the SSD drive (or only for a moment then as soon as i try some action on it (like a disk verification) it stalls and then disappears)

- Try to OCZ toolbox to make a security erase and start fresh. I had here a major issue, the OCZ toolbox would not start, it froze after a lot of complaints a "Scanning for hard disk partitions and creating /etc/fstab" and wouldn't move.

- Dissassembled the Mac Mini, removed the SSD, put it in a Macbook Pro, use OCZ Toolbox on it, this time, it loaded perfectly, identified the disk, i did a firmware update to the latest (1.37) and performed a security erase. All went perfectly. For verificiation I rebooted in recovery mode from the Macbook with the SSD and formatted properly the disk using the Apple Disk Utility (GUIP partition table+ HFS+ partition) and the system neatly identified it as a good host for system install. Then i removed the Vertex 2 SSD from the Macbook pro, put it back in the Mac Mini (reassembled it - god, that's a big pain !) and boot it again in recovery, only to see... nothing, the disk is still not recognized by the system.

Voilà... now I'm out of idea, It could be some low level hardware incompatibility, or anything else, i read about TRIM and Yosemite sometime not behaving well, about SATA II and SATA III compatibility problems, but so far, nothing clear.

I therefore welcome in anticipation your knowledge and hope we can figure this out. For the sake of extending the reach, I will also post this on Anandtech and Apple support forums. Links will be added.


AnandTech Forum

Apple Support Forum

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 3
2 opmerkingen

Can you verify your model info here as you have it make as a Late '14 model but your writeup implies you have had the system a 'few years'. So you have a late '12 correct. If you're not sure please supply the last 4 digits of your serial number so we can check it that way.


Also can you tell us which location you have the drive in top or bottom. The one you see first when taking it apart is the bottom bay. Also are you planing on using the second bay as well here.


Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

Hi Dan, thank you for helping. Actually, the "few years" system was refering to the SSD, the Mac Mini is brand new.

Actually I had the answer from OCZ support :

The issue is incompatibility between the older SandForce 1222 controller used in the Vertex 2 and the newer Intel Haswell platform used in the Late 2014 Mac Mini. The incompatibility started with the Intel 8 and now 9 series chipsets and spans across all products that used the controller regardless of manufacturer. It is expected behavior to be able to connect the Vertex 2 then clone to it, but if you try and cold boot to it the detection will fail. Unfortunately, the Vertex 2 and the controller it utilized are long EOL and never received a firmware update (if that was even possible) to adjust for the release of these new chipsets.

So I can stop looking around it simply wont boot, ever. Product being End Of Support, no new firmware will ever fix this.

So I guess, i'll have to look another SSD. Hope this can help other.

Was dit antwoord nuttig?

Score 4

2 opmerkingen:

Happy & sad here. Happy you figure it out sad its a new SSD. Please make your question as answered here as a good IFIXIT person takes the credit when you answered your own question ;-}


Neat, could find how to accept the answer before. Thanks for the support.


Voeg een opmerking toe

try to install "3rd party ssd support" from hackintosh MultiBeast software on the hdd then clone the system to ssd then try to boot)

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Nielluin zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 2

Afgelopen 7 dagen: 11

Afgelopen 30 dagen: 18

Altijd: 5,878