Fifth generation of iPhone. Repair of this device is straightforward, and requires screwdrivers, prying tools, and patience. GSM/CDMA / 16, 32, or 64 GB / Black or White.

2971 Vragen Bekijk alle

Silent/lock button causes intermittent vibrate

Hi all,

Odd one; keeping the Silent/lock button in the off position seems normal. Once the button is switched to silent/lock mode it activates and displays the transparent logo with a line through it, meaning the mode is active, thats normal too. However, intermittently the logo will show again with a vibration showing its now off, and then again with a vibration to show its on again, this continues at random intervals and sometimes multiple vibrations and logo flickers.

Anyone had this before? - I've checked the vibration module but not the headphone jack flex assembly yet, just want to make sure I'm not missing something before I open up.

Quick bullet point summary:

• Vibrate/silent switch intermittently vibrates and displays silent logo once switched on.

• Vibrate/silent switch physical movements seem solid.

• All other buttons work OK.

• Headphones working OK.

Thanks!

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

3 Antwoorden

Gekozen oplossing

It sounds as if the flex cable as went a tab faulty a new flex should sort out your problem that's the first step in the trouble shoot..

Oh you could also just restore to rule out corrupt software

Was dit antwoord nuttig?

Score 1

Commentaar:

thanks con, thought so, will tear down and check connections, rebuild. If no good ill replace the flex. :)

door

No probs if changing the flex doesn't work your probobly dealing with a motherboard issue.

door

Een opmerking toevoegen

Will, Can you give me information about did changing flex cable solve the problem or not? If not what did you do to solve problem? Thanks.

Was dit antwoord nuttig?

Score 0

Commentaar:

Sorry, yes - I had changed the flex cable and ensured the vibrator motor was seated correctly touching the contacts (and that no other dust/elements where making contact with them)

All seems ok now, thank you!

door

Een opmerking toevoegen

Hi, I have the same problem. This flex calbe I have to change, could you tell me what that is?

Thanks

Was dit antwoord nuttig?

Score 0

Commentaar:

The volume button ribbon cable which has the the vibrate / silent switch connected to it as well.

door

Een opmerking toevoegen

Voeg je antwoord toe

Will zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 2

Afgelopen 7 Dagen: 17

Afgelopen 30 Dagen: 67

Altijd: 4,963