Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

650 Vragen Bekijk alle

Backlight is unreliable, behaves intermittently

Hello! I have a laptop, serial F8V, that has an intermittent backlight -- sometimes it's not on when the laptop powers on, and sometimes it is. Sometimes the backlight doesn't come back when the laptop awakens from sleep. You can always generally get it back on, but it takes powering on/off, etc.

The board previously had some corrosion that was cleaned off, and previously was not powering on fully, and just showing a glowing sleep light. So that issue seems to be resolved, but now I've got this backlight problem.

The question is this: Would this problem more typically be the board itself, the topcase/keyboard assembly, or the screen assembly? I don't typically get a lot of the 15" unibodies, so I don't have a really strong sense of what the culprit would be. I vote that the board is bad, since it had slight corrosion (and unibody boards are generally so fragile anyway), but I thought I'd reach out and see if anyone has something interesting to add.

Thanks!

John

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 2

Commentaar:

Actually that's not the right machine -- it's a 2011 2GHZ i7 quadcore...for some reason EveryMac.com doesn't seem to have its database updated, so it brings up the 2.9GHZ retina i7 instead . When I first plugged it into EveryMac I got really excited, but I quickly realized that it's clearly not the retina model (for one, it has RAM slots).

door

Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

The most common problem I've had with these machines is the hard drive/ IR sleep sensor cables going bad. They create all sorts of maladies including sleep and back light issues. They will also destroy hard drives. So try replacing the cable and use a hard drive from a known good machine (any 10.7 + system works for me. If nothing else it's a cheap repair attempt and the first thing I do on these machines. (so keep extra 13" & 15" cables on hand).

Was dit antwoord nuttig?

Score 3

Commentaar:

Thanks Mayer! I'm glad I asked, because I never would have guessed that one! So if I don't have another cable, I assume I can eliminate that as an issue by simply disconnecting the cable, and if the issues stop, then that was probably it? Thanks again!

door

Don't assume anything on these. Remember you loose the sensor when the cable is disconnected. On the newer machines the cable is double the width of this one and there is a rubber bumper on the top of the cable as it goes over the upper edge. I've used the newer cables on the older machines and they work fine. See this question: Using new hard drive cable in older machines 821-1480-A

door

Voeg een opmerking toe

Have you tried resetting PRAM ? (Booting with Cmd+option+P+R keys)

Next step you can do is trying to reset SMC. (This progress is hard to explain so I refer you to apple's website for that Resetting SMC)

Next up is finding the connectors on the logic board which lead to the backlight. If you see any corrosion/soldering damages, then u might have located the problem. I do not own a tech manual for mbp atm but I'm sure someone on this website can provide you with the location of the connectors on the board.

Was dit antwoord nuttig?

Score 1

Commentaar:

Yes I've done all the resets and removed all visible corrosion. Thanks

door

Voeg een opmerking toe

Voeg je antwoord toe

rdklinc zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 2

Afgelopen 30 dagen: 4

Altijd: 882