Ga door naar hoofdinhoud

Repair information for Sharp televisions.

104 Vragen Bekijk alle

Sharp 50" Roku TV powers up but quickly goes dark (Model LC-50LBU591U)

My tv recently started going dark shortly after turning on. This happened a while ago, but was fixed with a reset and a lot of time being left off. I have tried resetting it again and can't get it to stay on past the loading screen. I have tested the power board and believe everything is fine but I'm not exactly sure what every voltage should be. The backlight remains lit when the screen is dark and I'm not able to see any images when I shine a flashlight on the screen. Does this mean I should replace the main board? I have no problem replacing the power control board or main board, I would just appreciate some help figuring which one instead of buying and replacing both. Thanks in advance!

Edit- aging some pictures for clarity

Block Image

Block Image

Block Image

Edit- to add other board. The only difference between it being disconnected or connected seems to be whether or not it shows the sharp logo before flickering and going dark. When it's disconnected, it just goes straight to the blank screen, when it's connected, it tries to work but flickers out

Block Image

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 1

1 Opmerking:

@nathanfortier do you have audio at all?

door

Voeg een opmerking toe

1 Antwoord

@nathanfortier I know you said your back lights stay on but let's start from the beginning. Just in case.

This could be any of the 3 boards. If you have sound, then the T-con board would be my primary suspect. If you do not, then it's a toss up between the main board and the power board. It'll depend on the voltage to and from your power board/main board.

First you need to verify that you have no image on all inputs. Try all of those. If it remains dark, unplug everything that is plugged in the back of your TV. unplug the TV and push the power button for about one minute, then plug it back in. See if that resets your TV.

If it remains dark, turn the TV to a channel where you can hear the sound. Next, use a flashlight and shine the beam at an angle against the screen. See if you can make out shadows or shapes. If you do, then it is your backlight that has failed.

If you do not see anything, unplug your set and remove the back cover. Then visually check the boards for any obvious damage like domed or leaking capacitors. Check all the wiring and unplug the wires and plug them back in, make sure they are properly seated. Post some images of all of your boards with your question.

Use this guide Voeg afbeeldingen toe aan een bestaande vraag for that so we can see what you see. It is possible that this is either a power board issue or a T-con board issue.

Was dit antwoord nuttig?

Score 0

5 opmerkingen:

I can't really tell if I have audio or not because I can't navigate to a place where there would be audio. But I removed the back cover previously and could see the lights are on. There wasn't anything obviously wrong with the boards (capacitors looked good, no burn marks, etc.) but I can post some pictures just in case I've missed something. And I wasn't able to see anything when I shined a flashlight on the screen. But like I said, I can see that the backlights are coming on since I've taken off the cover and can see it shining through the back when I push power.

Edit- forgot to mention that there isn't anything plugged in. It's a Roku TV so it normally boots up and goes to the Roku home screen but it flickers and goes dark before it gets to that point. Thanks for the help!

door

@nathanfortier Yes, pictures always help with remote repairs :-) That way we are all in the same book. Backlight on no image (sound we don't know yet) could be any of the boards, including the panel. The power board is not ruled out, but moves to the bottom of the list since it does supply the power to the backlights. We know that at least some of it is working.

door

@oldturkey03 yeah, that makes sense. I edited the original post to include pictures of the boards and to show that the lights do work even though the screen goes dark

door

@nathanfortier give us a good close up of the T-con board. That is the board where the ribbon cable from the main board terminates on. Nice and big so we can identify the circuitry and have you check a few things. In the meantime, try this. Unplug your TV, remove one of the ribbon cables from the T-con board to the LCD panel. Plug your TV in and try to start it. Any change? Try the other side too. Always disconnect the power before disconnecting and reconnecting the ribbon cables.

door

I have this same problem was there any solutions? And maybe could it be the ribbon. I have sound and the leds are on but no image.

door

Voeg een opmerking toe

Voeg je antwoord toe

Nathan Fortier zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 5

Afgelopen 30 dagen: 54

Altijd: 305