Ga door naar hoofdinhoud

The larger edition of Samsung's tenth flagship Galaxy phone, released in February 2019. Shipped with Android 9.0 (Pie).

111 Vragen Bekijk alle

Galaxy S10 won't turn on after battery change (it's not a bad battery)

Hi! I just did a battery replacement following the guide here, on iFixit, on my wife's Samsung Galaxy S10+ and everything was going on just fine, all the pieces where coming off as they were supposed to. In the end, I swapped the battery, but the new one in place and tested it to see if it would power up. It didn't, but I didn't think much of it, as the battery could be dead. I closed everything up and tried again. No joy. I powered on the phone and it did startup, then it stopped and showed the water damage warning. I used Isopropyl alcohol to loosen the adhesive and I had to use quite a lot. I didn't have a needle, so I had to improvise with the pick and slowly dripping it against the pick into the battery holder. There was some spillage, though, but I did dried it up with a cloth before connecting the battery. Anyway, I thought: well, it's alcohol. It was late, I just wanted to get to bed and, you know... it will dry up during the night and in the morning and it will be ok. I unplugged the phone and just left it there.

Morning came and I went to check on the phone. Now it won't even power on or show the water damage warning. I did a full tear down, checked the connections, checked for corrosion, everything I could possible think of and I can't find a reason why the phone seems dead (other than somehow the alcohol shortened a circuit in the board). I also used a blow dryer on the parts and that for sure got all the alcohol out. I also checked on the humidity sensor on the sim card and it wasn't tripped.

Does anyone know if there's any part that's essential to be connected, like an anti tampering sensor on the case, that prevents the phone from being turned on without a connection?

If someone has any ideas on how to further troubleshoot this, I'm all ears. I'm not an amateur on these types of repairs, so feel free to go as technical as you want. I saw a post by @oldturkey03, on another thread, with a flowchart of the troubleshooting process and I'm very much interested in following it, but I haven't seen the markings of the parts he's referring to, so I'd appreciate if someone has more information on how to find these parts or a more extensive guide.

Thank you so much for taking the time to read this!

PS: I have, of course, tried to power on the phone with the old battery, which was still usable and had around 20% charge, and closed up the phone before plugging it in unsuccessfully

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
7 opmerkingen

@casually8728 on which question did you see the flowchart? What markings? What kind of isopropyl alcohol? ¯\_(ツ)_/¯


@casually8728 okay I see what you are looking at. Hard to measure components output if the components are not marked. Let me fix something for you.


@casually8728 What kind of isopropyl alcohol?


@casually8728 let's see if one of the phone guru's has a trick up his sleeve. @tech_ni knows his way around Samsung and other mobile phones


2 commentaren meer tonen

Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

@casually8728 okay. Give the troubleshooting flowchart a try

Block Image

Now open the pdf file S10plus Component Layout and use the search function for the component you are looking for i.e. L8026 etc. Your PDF reader should show you where it is located. Let me know if this works for you.

I am a bit concerned about the water damage indicator.....We may ask you later to post some GOOD pictures of you circuitboard with your question. Both sides and pretty clear will always be helpful.

Update (05/16/23)

@casually8728 something like this is what I am referring to by circuit schematic

Block Image

this shows your U12003

Update (05/16/23)

@casually8728 I guess anything is possible :-) It looks like you should get battery voltage on L5039

Block Image

The parts are as follows

C5040 2203-009618 Capacitor 22UF,20%,16V,X5R,1810 package (Metric)

L5039 2703-005067 Inductor 470NH,+30/-10%,2012 package (Metric)

and those will require to be soldered into place after you desolder the old ones.

Still check those parts that are suggested in the flow chart.

Was dit antwoord nuttig?

Score 2

45 opmerkingen:

Thank you so much, I'll give it a look as soon as I'm able, I should be able to find some time tomorrow and get these measurements. Would it be possible for you to re-upload this file as it appears to be corrupted?

Also, I just checked the packaging and it was a 96% isopropyl alcohol

Thank you!


@casually8728 see if it works from here. Mine opened perfectly in the iFixit window


@oldturkey03 The first link worked on a PC (I was on mobile before). The other one is actually giving a 403 forbidden, you might need to tweak the sharing settings. Anyway, I'm set for now as I was able to access the first link.

Besides following this flowchart, do you have any idea on anything else I should do? Thank you!


Also, I can't spot the R304 on the diagram... Is it a typo? I can see R3014 there, it seems that all R codes have four digit numbers after the R


@casually8728 no idea why it did that since they both linked to the same file. Anyhow, i delete the last one. You are right about R304 and I am checking if there is a real schematic for the traces etc. out in the wild yet.

Follow the power by checking your battery level and your charging port. check for the proper voltages on the coils "L" for U12003. Also check around U8015 since that is the secondary PMIC. I let you know if I find the schematic.


40 commentaren meer tonen

Voeg een opmerking toe

I can't see isopropyl alcohol shorting anything as I've submerged boards to clean them with no issues. You didn't say but I take it there's no vibration either when you try and turn it on. Have you checked the battery connector for damage under magnification at all?

Was dit antwoord nuttig?

Score 1

1 Opmerking:

There is no vibration whatsoever. I didn't check it under magnification as I don't have a magnifying glass, but it doesn't seem like it. It also doesn't explain how I would be able to turn it on after the battery swap, and then after a couple of hours without anything done on it (it was just sitting at my desk while I slept) I wasn't able to get to the battery charging animation or the water damage animation


Voeg een opmerking toe

Voeg je antwoord toe

Casually8728 zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 2

Afgelopen 7 dagen: 13

Afgelopen 30 dagen: 76

Altijd: 1,495