Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

825 Vragen Bekijk alle

you need to restart your computer... and water damage


I have a MacBook Pro 2,4 GHZ Core 2 Duo, it has an water damage.

I cleaned wirth 99% Isopropanol.

It is loading on the charger, and everything is fine, but when I start the MacBook I get the kernelpanic picture.

I did the HardwareTest from the Apple DVD, averything is ok, no damage, with the short and wirth the larger hardwaretest.

I tested a new RAM and I booted from the harddrive and from a USB-Stick.

Whatever I did, I get the kernelpanic.

Thanks for Help!

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Een opmerking toevoegen

Gratis verzending van alle bestellingen van meer dan US$ 100 of met een Pro Tech Toolkit!

Doorblader onze winkel

4 Antwoorden

Gekozen oplossing

What you must determine is if the issue is logic board related or originate from another sub system component. To do so a tech will perform many actions such PRAM, SMC resets, swap ram sticks between ram slots, try known working ram, boot from external source,perform the Apple hardware test, etc. If the problem cannot be found using these actions he will open the machine, disconnect everything from the logic board except the fan(s) and magsafe dc in board (which should be checked too), then power up the machine directly from the logic board power pads. While doing this he will use an external monitor, a usb keyboard, mouse and headphones (or external sound system) to monitor a chime at startup. If the issue persists then there's a real possibility of logic board failure and a logic board swap can now confirm the diagnostic. If the machine start OK with three beeps he can now add a known working ram stick and reboot the machine again via power pads checking for the interrogation icon on the external monitor. He will then connect other components (airport card, optical drive, hard drive, etc) and boot the system between each connection until the culprit is found. In your case, since the issue probably comes from the liquid spill, the logic board must be cleaned and inspected before testing it. All connectors, sockets, ram slots must be checked with a microscope or a magnifier for any damage (short) or corrosion. You must also closely look for any color change, black spots, damaged ICs on both logic board sides. Additional tests can be performed with tools such as multimeters and oscilloscopes.

Was dit antwoord nuttig?

Score 3



thanks for your answer lemerise!

Most of these stuff I cant to dit, because MacRepair is just my hobby.

Du you know how I can start this MacBook Pro without the powerbutton? I think I have to brige something, but I dont no what exactly.

I dont found any more liquid spill, but two black spots on the conector für the LCD, but the LCD is running, strange?

Thanks for your help!

greetings from Germany


Hello, I have news.

Current I cleaned the logicboard again an now, the MacBook works.

It is booting from the harddrive and I got no more kernelpanics.

But when I want to boot from the usb-device I got the kernelpanic.

It is really strange what happend in the last 24 houres with this macbook. The problem is, I cant sell it like this, or give it away.

Thanks for helping.


ABCellars would be better than me to describe where this component is located on the logic board but I think there's a big chip labelled INTEL that drives the MBP USB functions. Maybe it would need to be verified and cleaned again and I would also check the USB ports and ports contacts to the logic board searching for any abnormal sign. Be aware that the KPs could also be caused by something else ?????


What means KPs? When that MacBook is booted and I put the USB-device in the usb port it works


KPs = kernel panic events. From which USB device did you try to boot the machine ? Tried the two USB ports ? No KP when booting from the optical drive with the same media used in the device connected to the USB ports (I presume it's an installation disk) ?


1 commentaar meer tonen

Een opmerking toevoegen

Do you have a system install disk that's on an optical disk (CD or DVD)? Is this USB thumb drive the only external disk you've tried?

The gold standard for a system installation is off the grey Apple DVDs included with the computer. Try that first, if you can. You can also use a retail Mac OS X install DVD; the minimum system required for your computer is Snow Leopard 10.6.3 - nothing lower than that will boot your computer.

One issue is to isolate whether there is a general USB problem, or a problem with this specific USB drive. Try plugging an ordinary working USB mouse into each port, and check to see if it works. If the mouse doesn't move the cursor in one or the other port, it's likely that a port has burned out. If neither of the USB ports works, it's possible that the USB controller has burned out - or possibly that the USB drivers have gotten goofed up, and need to be reinstalled.

What do you believe is on the USB drive/stick? My suspicion is that USB works fine, but you're trying to boot off a USB stick that isn't actually bootable. If you start from the hard drive, and then attach the USB stick, what happens? If a disk mounts on the desktop, that's good; if it appears to be an OSX install disk, that's better. But if the OSX system is older than the one that the computer was built with, it won't be bootable.

Launch System Preferences, then select Startup Disk. If the system on the USB stick is bootable, it will appear there.

Was dit antwoord nuttig?

Score 2
Een opmerking toevoegen

If it's booting OK from the system installation disk, I would reinstall the system.

Was dit antwoord nuttig?

Score 1


Thanks for your comment!

I tested it, but when I boot from the system installation disk I get the kernel panic.


Een opmerking toevoegen


thx for help from everyone!

I found the problem :-).

It was not a hardware problem, it was a stupid mistake by myself lol.

I used a older version from Mac OS X.

On the USB Device was a version older than 10.6.3

And the first installation dvd was just 10.6

both of them I got the kernelpanic.

Than I used the original installation dvd with 10.6.4 and it worked.

I installed this version on the USB-device and after the installation I can boot from the USB-device!

Thanks for help, you and I fixed it ;-)

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

mfolta83 zal eeuwig dankbaar zijn.

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 3

Afgelopen 30 Dagen: 15

Altijd: 2,107