Ga door naar hoofdinhoud

Repair guides and support for your Samsung TV.

2358 Vragen Bekijk alle

Tv turns on and off, with no screen.

Hi there, my name is Eli and my tv model is UN70NU6070FXZC. I have a similar issue to this: I think T-CON board is bad, but I don't know where it is

The problem I’m having is that my screen remains black and turns on and off every couple of seconds. So I’ve went out on a limb and replaced the main board and power board, to which I’ve had no success with. So I did some experimenting: When I unplug one end of the ribbon cable going from the main board to the driver board, turn the power on, and THEN plug the ribbon cable back in, I get full picture, along with the power remaining on (tv functions like a tv). However, if I was to power off, I would be back at square one and would have to redo the steps above to get it working again. The other issue that I’m having is that when I plug in an HDMI cord when the tv is functioning, go to source, and select HDMI, the picture from the HDMI works for about two seconds, and then goes back to square one with flickering power and no screen. After reading through the link above, I have also triangulated the issue to the driver board, however I don’t know where to go from there. Any help would be greatly appreciated. Thanks.

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Block Image

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

Eli since you already replaced the boards the only thin that can be going on with it , is that either the ribbon cables are short somewhere, or the driver boards have failed. There is not a lot of information available for those, since they are considered part of the panel and can only be replaced via a special process. Give us the numbers you find on those boards and we'll try to get as much as we can. Take a close look at those, see if you notice any "odd" looking component etc. Watch out for the fine ribbon cables that attach to the panel. Those can be frail and don't want to tear them. Change your ribbon cables as well (your boards were new when you bought them?)

Was dit antwoord nuttig?

Score 1

3 opmerkingen:

For the driver board, the sticker on the left ( if seen front the front) says SPWBL695G004 1309906Q4339, (other sticker is covered with tape), and the one on the right says SPWBA695G004 13099Q5G4863 (again other sticker covered with tape). I didn’t notice anything weird on them, and the boards that I bought were most likely scrapped from other tvs, but we’re sold by the company tvpartstoday.

door

Although, after a long time I may have figured out a potential solution to it. Have you heard of taping the pins on the ribbon cable? I’ve been doing that and currently I’m getting good results: tv remains on, picture shows, no lines, does all this when powered off and on too. The issue now is that one half of the picture seems to have lowered contrast compared to the other half which looks bright and normal. Also, when I plug in an HDMI, it shows picture from it for a longer duration (10-15 seconds) before not completely turning off, but bringing me back to the source page saying HDMI no signal. I just don’t know what pins I should tape up and what pins I should leave as is. Thanks.

door

Eli tvpartstoday is pretty reliable but this "from it for a longer duration (10-15 seconds) before not completely turning off, but bringing me back to the source page saying HDMI no signal" would be either a main board issue or your HDMI cable.

door

Voeg een opmerking toe

"HDMI no signal" would indicate a different problem.

There have been other posts here that point to the panel and maybe that is because the driver boards on the bottom can't easily be changed.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Eli zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 5

Altijd: 33