Ga door naar hoofdinhoud

Repair information and guides for the iPhone 6 Plus that was released on September 19, 2014. Model: A1522, A1524

1510 Vragen Bekijk alle

iPhone restore bar stuck at 99%

I had previously fixed this by having something inserted in the headphone jack, but it seems that doesnt work anymore.

When the phone was working bluetooth and wifi didnt work except on one reboot they did. The apple store also doesnt work except on that one time where the wifi and bluetooth also worked.

I was dumb enough to try and update to 12.5.6 and now im back in the same situation of the restore progress bar being stuck at 99% (being 0.5cm away from complete)

This seems to be because wifi doesnt work, so is there any way to force it to complete?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
1 Opmerking

btw i can ssh into it


Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

There is no way to force it that I know of. You would have to resolve whatever the underlying issue is. It could definitely be that the WiFi and Bluetooth being faulty is causing issues, I don’t recall whether or not those are necessary for update, but I suspect they will be.

If you really want to dig into what’s going on, I would recommend checking the iTunes logs. That might give you a clue as to what it’s actually stuck doing. On Windows, those logs would be stored in your user folder in the AppData folder (which is hidden by default, but can be unhidden by ticking the Hidden Items box on the View tab in File Explorer).

The full path would be (assuming C is your Windows drive) C:\Users\<your user account name>\AppData\Roaming\Apple Computer\iTunes\iPhone Updater Logs. You’ll want to scroll all the way to the end and just have a look at what it is says it’s trying to do. Screen cap it and attach to your original question if you want some additional input.

Was dit antwoord nuttig?

Score 1

3 opmerkingen:

checking the logs, the wifimanager thing seems to crash constantly, it also says something about photo library not ready. Here is a snippet of the logs:

Sep 20 19:02:45 francs-iPhone assetsd(PhotoLibraryServices)[155] <Notice>: Photo library is still not ready for Cloud Photos. Waiting

Sep 20 19:02:45 francs-iPhone mediaserverd(CoreMedia)[26] <Notice>: <<<< TimeSyncClock >>>> figTimeSyncClock_Monitor: nowMonClock: 4871.622314; lastMonClock: 4861.508839; nowMonNet: 4871.622 (0xa31828d014400000); lastMonNet: 4861.509 (0xa31828d014400000); nowMonRef: 4871.622; lasMontRef: 4861.509; lastSynthAnchor: 4871.622; lastGM: 0xa31828d014400000; offset 0.000; lastRefTimelineAnchor: 4871.622

Sep 20 19:02:46 francs-iPhone mediaserverd(AppleTimeSyncAudioClock)[26] <Notice>: gPTPClockStatistics for 0xa31828d014400000

Sep 20 19:02:46 francs-iPhone mediaserverd(AppleTimeSyncAudioClock)[26] <Notice>: Grandmaster Identity: 0xa31828d014400000


Sep 20 19:04:00 francs-iPhone ReportCrash(CrashReporterSupport)[1231] <Notice>: Thread 4 name: WiFiManagerThread

Thread 4 Crashed:

0 MobileWiFi 0x00000001c6e83f70 0x1c6e74000 + 65392

1 bluetoothd 0x0000000100aad00c 0x1008cc000 + 1970188

2 libsystem_pthread.dylib 0x00000001bb7152c0 0x1bb70a000 + 45760

3 libsystem_pthread.dylib 0x00000001bb715220 0x1bb70a000 + 45600

4 libsystem_pthread.dylib 0x00000001bb718cdc 0x1bb70a000 + 60636

Sep 20 19:04:00 francs-iPhone ReportCrash(CrashReporterSupport)[1231] <Notice>: Thread 4 crashed with ARM Thread State (64-bit):

x0: 0x0000000000000000 x1: 0x0000000100aad1d8 x2: 0x0000000119d299a0 x3: 0x00000001c6e83f70

x4: 0x0000000000000000 x5: 0x0000000000000000 x6: 0x0000000000000000 x7: 0x0000000000000000

x8: 0x0000000100d45000 x9: 0xaaae9eaf02d400c4 x10: 0x00000000000335fc x11: 0x0000000000000000


Sorry for the delay in response. It could be the non functional WiFi is actual causing the issue. If this thread keeps crashing, it could certainly keep the machine from finishing the process.

If there is further activity after the iCloud Photos mention (the log is generated in chronological order, so the items at the bottom will be the most recent, and likely the cause of the hang) it may be that this is normal. Sometimes things in these logs which seem like an issue aren’t actually.


Voeg een opmerking toe

I guess I am not sure how you are attempting to restore the device but Apple has a guide that you can use. You download the version of the OS you need onto your computer and connect your device VIA USB. You won't need the onboard wifi that way.

Alternatively, when I do system resets or restores I use a third-party software called Dr. Fone. It works great and fixes most all software issues I have had in the shop. I am not sure what an individual account costs, but my shop's account is pretty expensive. You could check that out or try to find an alternative.

Was dit antwoord nuttig?

Score 0

2 opmerkingen:

I updated with itunes and 3utools, the problem is i believe the iphone needs the wifi ic to work to successfully restore


Oh and, dr. fone is a total scam. Its just a glorified itunes restore except that you pay 30 bucks to do it, and probably lose all your data.


Voeg een opmerking toe

Voeg je antwoord toe

Light Yagami zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 5

Altijd: 88