Ga door naar hoofdinhoud

The Logitech VX Nano is a wireless laser mouse designed for notebook computers. The mouse includes a USB receiver that can be stored within the mouse or inserted in a computer or laptop’s USB port.

1 Vragen Bekijk alle

Mouse won't power on

My Logitech VX Nano Wireless Mouse won't power on. I replaced the batteries. And no, the receiver is not in the storage slot. It is not a connection issue; it was working fine, then stopped. Thought it was the batteries, but new ones did not cure the problem. I can't find any troubleshooting for this problem.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
3 opmerkingen

can u take a pic of the board plz


Hi @kamsh

Had you tried with another computer?

Is the usb receiver detected on the computer? you can check on device manager.

when you pull out the new battery and insert again, do you see any LED light showing up on top of the mouse?


I have the exact same problem. The USB receiver is detected but none of the LED lights are lighting up when batteries are inserted.


Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

if its not getting any power light then its a power issue.

did anything happen suddenly before the old batteries die? any possible liquid damage?

might sound silly and i HATE to ask but are the batteries in the right polarity?

and youve obviously tried confirmed fresh batteries?

are they rechargeables ?

have you checked to make sure the contacts are extended enough for the negative to make a solid contact with the batteries?

any corrosion?

if youve checked all that you may need to open the mouse up and take some voltage readings and make sure the board is getting power. if it is then you have a bigger issue and will need further trouble shooting.

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

When you insert the nano receiver in is't slot next to battery compartment, the receiver push a button inside the mouse to disconnect power to conserve battery. This function is in replace of a power switch that not available in VX Nano.


The push button inside the mouse need to be cleaned or replaced.


Voeg een opmerking toe

Voeg je antwoord toe

kamshopping zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 4

Afgelopen 30 dagen: 12

Altijd: 345