Ga door naar hoofdinhoud

Model A1418 / Late 2013 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

241 Vragen Bekijk alle

Catalina fail to install after HDD format resulting in error PPPM003

Hello,

so my late 2013 iMac was running a little slow in the past few months therefore I decided to format its hard drive and do a clean Catalina OS install. All went fine until the OS installer failed to complete the task and gave an error that it was unable to do so. After a few tries hoping it was some internet flaw it became clear that something was up. So I did a diagnostics test on boot and got no error code at first, which was odd. After a lot of tries and confusions I repeated the diagnostics test, finally showing an error code: PPM003. After looking on AHS code references it showed that was a “failure at integrated memory level”. That got me confused cause that iMac doesn’t have inboard memory as far as I know but anyway. So I brought the computer to an apple service provider so they could swap the memory modules and see if it worked.

The technician that worked on my iMac said that it was the hard drive that showed that it was worn down so that I should swap to an SSD. I said ok since it was something I wanted to do anyway. After that he reran the AHT tests which still showed the PPM003 error plus he said the computer was indeed slow on boot which was odd considering the new SSD. Then he ran the tests with their in-house new memory modules which still showed the error. I told him to do the test testing separate memory modules in case it was only a single one at fault and still showing the same. So now he doesn’t know what to do and neither do i.

So after all that I wanted to ask. Could this be a logic board problem or is apple diagnostics messing up? Sorry for the essay but I really like this computer and want to get it fixed.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

Commentaar:

So. Maybe this is a long shot, but are you sure it’s not PFM003? Because you’re correct. This unit does not have onboard memory so it would be an odd result to give. And faulty memory is more likely to cause crashes than slow performance.

But based on the symptoms you’re giving it’s possible that this is an error with the SMC. Which could be a sensor error. This would in fact cause the unit to run really slowly. If this is what's going, it's also extremely likely the fans would be running at full speed near to constantly.

door

Hi,

Thanks for the reply. So I double checked and it was indeed PPM003. Before the format and the whole debacle the computer was slow but nothing huge otherwise I would’ve done the format earlier. Also the fans were probably running at regular speeds cause nothing was audible, but again emphasis on probably. The technician suggested that it’s the logic board and that only replacing that it would fix. However I found it odd because if it was wouldn’t it give a specific error for that? And they don’t even have the board to replace because they don’t have one new and, according to him, Apple doesn’t have to provide new parts for products older than 5 years zzzz.

door

What also threw me off is that once he replaced the HDD with the SSD he was in fact able to install Catalina and boot it. He claims that now with my old memory the computer is running but booting slowly taking about 30 secs to do it. I mean it’s an old iMac and stuff but should be way faster imo with the SSD. My big question at this point is if I should settle for spending money with the SSD and use it as is or try to also fish for a secondary market logic board and try to replace and see how it goes.

door

Got it, really that was a total shot in the dark anyways. I'm still not sure why it would be giving that error, and 30 seconds for boot I suppose seems a bit long, but depending on the other specs of the machine and exactly which SSD was installed, I don't know that this is entirely out of the norm.

door

Voeg een opmerking toe

1 Antwoord

@gu_voss - You clearly have a SMC error condition! The system is in CPU safe mode, basically the CPU’s clocking is reduced and the fan ramps up.

As to why this is happening is do to the loss of a critical sensor! Let me explain…

Apple contracted custom HDD & SDD’s which expose the drives internal thermal sensor for SMC to access so it can monitor the drives heat. So your friend took the HDD out putting in a SDD in its place but…

The SSD he put in is not running the custom Apple firmware (as its not an Apple drive) or one of the newer S.M.A.R.T. drives which have the updated ability for the system to access the drives thermal sensor.

Apple Petitioned the standards to offer a better means to access the thermal sensor. The older method required a IRQ request which doing once and awhile is not big, but Apple is calling it every ten secs or so. This would in turn slow your system down big time!

Remember Apple uses custom 3.5” HDD’s in the 27” systems and they face the same problem! But Apple never altered them as it was less of an issue as there was a spare SATA port so a dual setup could be used leaving the HDD in place working or not!

So your solution is getting a currently manufactured SSD which has the newer S.M.A.R.T services.

Was dit antwoord nuttig?

Score 0

Commentaar:

Hey Dan thanks for the answer.

My question is why did the computer fail to install Catalina in the first place. Was it the HDD all along that caused the OS install failure and the slow computer?

The technician told me the HDD was at 91% functionality but no clue what that meant. Seems weird that it didn’t give any HDD related error and only the PPM003, which maintained after the swap to SSD.

You logic tells me that the first problem was the HDD that caused the failure to install and then after the swap the new unoptimized SSD became the issue, basically tomato tomato.

I’m only thrown off by that dumb error. Wouldn’t the SMC error also be evident? I triple checked the code. Regardless I will ask which SSD was put in, since the iMac is still at the service center. Really appreciate the input.

Can I also ask the technician to run some sort of test to verify that? If so do you know which one specifically? Because he said he did all the Apple hardware tests and they all came normal other than the PPM003 error.

door

Can't tell you why your Catalina install failed. OS installed are I/O intense so it just could have been the straw that broke the camels back!

I love it! The tech tells you the drive has 91% functionality! So if the doctor told you that about your Heart or Kidney what would you do? Get on the waiting list for a replacement right? At least thats what I would do! So replacing the drive was needed.

PPM003 error is onboard memory problem, but you got a double whammy here. As the drive also failed. So is this a fleeting error or the root issue? You claimed to have run the onboard diagnostics at the start not getting any error. Which is why I jumped onto the drive as it came back bad (per your tech)

Are we sure we are going down the right path?? Did the tech even try a fresh set of SO-DIMM memory? Or at least clean the contacts.

door

Voeg een opmerking toe

Voeg je antwoord toe

gu_voss zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 7

Altijd: 66