Fuel Gauge IC not working but fuel gauge not faulty

Alright got a weird one here for a nintendo switch, feel it's on the cusp of life but just can't figure it out at this point and hopefully someone can shed some light.

So switch is a faulty ebay purchase apparently it was taken to a repair shop who failed and the customer just sold on. However the p13 was shorted and around 12 caps/resistors/filters missing around the p13 as well as a tampered bq chip, a cracked fuel gauge and a couple other missing components.

So after rectifying the p13 chip and replacing all the components we were met with a blackscreen upon boot at 0.4a charging so I suspected auto rcm or dodgy nand so I booted into hekate and rebuilt the nand from scratch as I obviously do not have a working backup. All is good despite the fuel gauge ic error in the screenshot and I go to do first boot and we get the nintendo logo followed by blackscreen and then a 0.4amp draw again.

Suspected the donor board fuel gauge I used was bad so tried another, same result, so bought a brand new one but sadly same result. So I decided to just replace the entire fuel gauge circuit (the surrounding components on the fuel gauge) as well as replace the BQ chip as it looked tampered with and just for the !&&* of it threw on a brand new m92 too. But lo and behold the error still remains. Have tested with different batterys and switch housings but same result.

As a hail mary I also removed the diode arrays as I know they can cause charging issues but aren't needed.

At this point I'm at a complete loss. I do believe the fuel gauge is what's preventing the boot up however I can't be 100% sure but I do know the nand rebuild/downgrade has been carried out properly as I've done it many times but this switch is a real wrench in the works and haven't come across this in about 30 switches.

Thanks for any and all advice!

Block Image

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

Commentaar:

Tried a different battery ?

door

@tech_ni Cmon bro, I went through the effort of testing this in-depth and writing out a descriptive post. Least you coulda done was read it before posting man, yes I've tried different batteries.

door

@FiddyOnFiddy I thought I had read it but somehow missed the battery part, what about the max ic below the apu

door

Voeg een opmerking toe