Ga door naar hoofdinhoud

iPod Classic 6th Generation. Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

905 Vragen Bekijk alle

6th Gen 80GB iPod classic not connecting to iTunes all of a sudden

I have a daily-driven iPod that I use all the time since about 3-4 years ago, but only today when it started acting up by not connecting to iTunes. Tried diagnostic mode, tried disk mode, and rebooted about 20 times to no avail. Basically doesn’t do anything when plugged in, but charging seems to work still (the icon is not there but the battery stays full while playing, so I am guessing it’s receiving power)

And then I noticed that there's a pin that seems to be out of the socket, but couldn't be sure whether that's supposed to be there or not. My iTunes is otherwise connecting to my other 5th Gen iPod just fine via my original 30-pin cable from Apple from 2005 lol

Block Image


Image of the pin: https://i.redd.it/6lmwqjc3hu681.jpg

Any additional ideas would be appreciated! Thank you!

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

@simonkhtse yup, its a broken dock connector. Here is the trick. It can still be repaired. All you need, is somebody that knows how to solder small stuff. Depending on your location, we might even know a few that are contributors on ifixit, and could help you out. The ports are still available at places like this and many others. Here is what the repair looks like

Don't you be giving up on this repair. Those classics are definitely worthwhile to repair.

Repair is War on entropy!

Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

Long story short, the 30 pin socket is broken due to that pin being out of its place.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Simon Tse zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 15

Altijd: 57