Ga door naar hoofdinhoud

Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

758 Vragen Bekijk alle

Early 2011 MBPro's new battery not charging

Hello everyone,

[TLDR: new battery, new MagSafe board, SMC and PRAM reset but battery not charging]

A few months ago, my venerable MacBook Pro's battery finally gave up. Its capacity had been decreasing but it suddenly dropped to 0, meaning that if I disconnected the cable, the system would immediately shut down. However, I was still able to use it with the MagSafe connected.

However, a few weeks ago, the MacBook began to shut down randomly, even after less than one minute of activity, without any load. I read somewhere that the MacBook pro is not supposed to run only on the MagSafe so I decided to replace the battery.

First I went to a Apple Store because I trust Apple regarding batteries. However, this model is not maintained anymore. So I investigated and found out that Newertech batteries are supposedly good. I bought one, installed it, the MacBook started and did not shutdown randomly the few moments I used it. So I proceeded to the so called battery calibration, the first step being to shutdown the MacBook, and charged it completely. However, I realized that it was not charging rather quickly. What happens: I connect the MagSafe, its light turns green, the battery indicator lights up with 2 dots and a third one blinking. However, a few seconds later, when the battery indicator shuts down, if I push the button, only the 2 dots will appear, not the third blinking one. I tried resetting the SMC and the PRAM but it did not help.

Newertech service told me to try another MagSafe, so I went back to an Apple store and over there the lights did not even turn on. I was unlucky because back at home it worked again. Anyway, I asked the vendor if it could be the MagSafe board and he answered that it could be that or a lot of other things on the motherboard as well. Since I just had bought a 100€ new battery, I thought I would give a try to a 20€ new MagSafe board and then eventually give up.

I just replaced the MagSafe board, reset the SMC and PRAM but the battery is still not charging.

So would you have any idea of the origin of my problem? Thank you!

By the way, I run Linux Mint on it, if it can help the diagnosis.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2

Commentaar:

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question

door

Voeg een opmerking toe

1 Antwoord

Make sure all the battery pins are connected and not dusty,

and all the wires are on the connector.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Jean-Baptiste zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 2

Altijd: 22