Ga door naar hoofdinhoud

Galaxy M30s Totally Bricked.

Hello everyone,

My m30s is bricked . The phone got off suddenly while operating youtube (A couple of apps were running in the background).

Phone was running Android 11 oneUi 3

I couldn't boot into recovery mode by pressing Power + Volume up button. Didn't work. Then read somewhere on XDA to press volume up and down together and enter download mode by connecting cable to pc.. I did that and successfully flashed the official Samsung firmware using Odin. Phone is still stuck on the Boot Samsung logo - powered by Android upon rebooting after Odin successful flash. I tried even entering recovery mode from download mode by pressing power+ volume down , releasing volume down after reboot and then pressing volume up for 2-3 seconds. I'm just not able to get to recovery mode at all. I just don't know what else to do now. Can someone please help me out.

Now after watching some fixes, i heated up the CPU and power IC, the phone did boot to Samsung only logo (which means the heating partially worked), it then rebooted back to the original Samsung - Powered by Android boot screen. i did a Power+Volume down, the phone switched off and now the phone refuses to switch on. All i can see is a Flashlight - Blinking at times and at times it stays just like that.

Voltage showing on battery after testing with multimeter only max 2.8 volts. Battery is 4.4 volts on the label and nominal capacity as 3.85 volts.

I need to know what does Flashlight on/Blinking + Phone dead indicate. Perhaps it could give me some clue as to which direction i need to get going.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 3

1 Opmerking:

Sure. Will gave to open up the panel again. Need some time.


Voeg een opmerking toe

1 Antwoord

Applying heat to a cpu is not really a fix, but if it did make a difference, it is possible that that chip has failed.

Heating can sometimes temporaly restore the function of the IC which gives you an idea that it needs replacing

If that chip is infact the cpu, then I think your out luck

Your batterg voltage is too low to boot the phone at 2V ish. It need to be at least 3.6V to 3.7V

You.could plug in the charger and take a voltage reading at the battery connector to see of the voltage there is higher then the battery while the battery is plugged in. That would give you a clue if the motherboard is charging the battery or not.

Was dit antwoord nuttig?

Score 0

19 opmerkingen:

2 chips are side by side, one is the power ic and the other one the CPU. i just applied some heat at that point in time. There are several YouTube tutorials which say heating solved it and others have reballed the ram and CPU (take it out and put it again). I just need to figure where exactly the problem is. The CPU , RAM, Power IC or the Battery ?

Also , Can the phone boot without the battery connected and only the power cord(type c) connected giving supply ?


As mentioned, heating is not a real fix, and is only temp. at best.

Some device can boot with the.cord only, but the majority can't, they will only bootloop at best with the cord only.

If heating the IC changes the behavior, it is more likely that the IC itself is at fault and not the solder joint. In that case reball it would not fix it.


On another note, Can you confirm you battery voltage again? Because in it is much too low to power the phone to begin with, and that is strange since you've mentioned having the phone in download mode. Are you able to get into download mode without the charging cable plugged in?


Hi, I tested the battery separately at closer to 2 volts- pretty low. Regarding download mode , it happened in the in the following sequence :

1) Boot logo - powered by android

2) Some loading screen indicating android was trying to boot up

3) flash light starts automatically and the phone restarts to boot logo mode - powered by Android and stays there with flashlight either blinking or staying on

4) after staying there for quite a while, I realized it was stuck again like it was always before heating it.

So essentially , now whenever I charge the phone rhrough power adapter, the only response from the device is the flash right staying permanently on, nothing else. When I disconnect the cable, the flash light turns off

I will now try your suggestion of checking the voltage at the battery connecter while the cord is connected to power adapter.


Ok, the battery voltage is much to low. It needs to be at least 3.7V.

In some phones, it's normal to only see the backlight and no image when the bsttery is that low.

Let me know if you need any help with testing the battery voltage at the connector.

Ideally you should take note of the exact voltage before you plug the charger, and then note what it is when the charger plugged in. It should now be sligthly higher.

If so let if charge for 15 min to 30 min and check the battery voltage again with the charger now disconected. Did it increased?


14 commentaren meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

lineofsight9865 zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 6

Afgelopen 30 dagen: 30

Altijd: 2,360