Ga door naar hoofdinhoud

Epson EH-TW650 3LCD, Full HD, 3100 Lumens, 300 Inch Display, Wi-Fi, Gaming & Home Cinema Projector - White

1 Vragen Bekijk alle

EPSON EH-TW650 - won't power on

I got hold of this EPSON EH-TW650 which won’t turn on.

Inserting the power cable, you can hear a whine from the power supply as it powers up for about 10 seconds before that is replaced with a higher pitched whine from then on. Power/status LED’s don’t light up, the fans don’t run, the lamp does not power up.

When I first received this projector, I stripped it down to take a quick look and put it all back together, and it turned on! It stayed working for a few days until one day during operation it died again.

What I have tried so far:

  • I have replaced the power supply entirely as I believed it was not providing power properly to the board (replacement power supply shows exact same behaviour as previous one)
  • Searched the processor board over and over again for obvious bad caps with a multi-meter (I am an absolute novice at this, so it’s possible that the board is shorting or something and I just can’t find out where). Part of me wants to doubt it’s the processor board simply because it was working totally fine just a few days ago

What is most likely to be the problem? I’m most confused because after my first strip down the projector started working again totally fine. I should mention that when it died again after my first strip down I was moving the projector and believe the power cord shifted slightly, which is when it died.

Note: I have tried powering the projector on with the lamp cover on etc… as I know that the projector won’t power on without the cover. The fans/status lights should power on whether or not the lamp cover is attached.

Here’s a video of me inserting the power cable, if you turn your volume all the way up you can hear the power supply

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 5
5 opmerkingen

Hi David....any luck with this issue. I have the same projector model and I have the same issue. Just missed warranty period by 2 weeks.

I checked caps with multimeter and some of them read 007 not sure if they are causing problems. I also checked power supply to mainboard and I read 12V. Please share your learnings, It would really help

Cheers, Charlie

door

This is a fantastic find. I have this Epson 650 projector too. And my one is also completely dead. I have watched a few vids on YT and it seems to be a common issue with Epson projectors. Anyway I have found about 6 smd caps that need replacing. I'll order that chip as a matter of good practice too. But I am struggling finding the value of the smd caps for this machine. I'm no electronics engineer though I do use a meter occasionally for my work. I have a reading of 09.95 on a good capacitor I removed and I know it's the 2 mm size I believe they call a 0805 but I would love it if you can confirm the value for me? I see you said your air tool blew one off so I'm assuming you had to order a replacement? I've asked several other posters but no one replies other than one guy who just said any light brown 805 smd is OK. I can't understand that myself. Thanks for any help in advance

door

Just noticed that the chip is on backorder with an 81 week yes 81 week eta!!! Well I'm hoping it's not the chip in my case but did I see someone say they had a spare? I'd love to buy it if still available?

door

Hey Lenton! I never actually figured out exactly the right kind of SMD caps to replace mine with but:

1. I really do think that you can chuck standard capacitors on the board and they will probably work

2. A fair few of the smaller capacitors are redundant or failsafes on complex boards like these - whilst I managed to put some of the tiniest SMD caps roughly back in place, some of them that blew away I was never able to replace - yet the projector still works perfectly many months on.

Were you able to run power through the board as mentioned in my answer, if so did the suspect chip heat up? I would bet if you can replace that chip, even with some missing capacitors, it will power up and work fine.

I did have a spare chip but I sent it out to another poster who had the same issue, so you're out of luck there. Perhaps there are some one ebay that you might be able to pick up?

Sorry I couldn't be of more help, good luck!

door

@davidhigginson Thanks for your fast response. I watched 4 YT videos all on Epson and all had no power. The repair was the same and it was 2 caps on the main board. I've ordered some 50v smd caps of the same size and will hope they do they job. It's always great to get other answers as it all helps. If It doesn't work, I'll have to track down the chip. All the best L

door

Voeg een opmerking toe

3 Antwoorden

Gekozen oplossing

@charlie54 You’re in luck! I just managed to fix it a few days ago. Apologies if you’re a bit more experienced at repairs and this is a bit dumbed down for you - but this was my process:

I basically used voltage injection to find the shorted component (there are just too many capacitors to test and my multi-meter was not good enough).

I removed all the connections to the motherboard apart from the main power connector (which you have the arrow pointed to in your image) and placed some kind of protective vinyl sort of mouse mat underneath the board to prevent it shorting against any of the metal components beneath. I then took the grounding wire that is attached to the motherboard near the speaker and screwed one end into the chassis and the other onto one corner of the motherboard so the board remained grounded.

I then plugged the projector into the wall outlet and gently ran my hand over the powered on board (keeping well away from the power supply), to see which of the components on the board was heating up due to a short. I tracked it down to a switching voltage regulator (part of a local power supply or a buck converter I believe), which was getting red hot to the touch. I was able to take a picture of the component with my phone, blow it up on the computer, find the part number, and order one (ive linked it at the end of the post).

The chip is the flat square black chip just to the right of my finger in this image. A different component might have shorted on your board, but it might be a good place to check.

Block Image

Process to repair

I spent some time watching tutorials on how to solder surface mount components like this tiny regulator, and then ordered the relevant parts to repair:

  • A gas soldering iron (my soldering iron was old and crap) which also had a hot air blowing function.
  • Cheap tweezers
  • No-clean Flux
  • Solder paste

I was able to use the hot air gun to heat up the chip enough that I could prise it off the board but in the process managed to literally blow away a couple of absolutely microscopic capacitors that were on the board nearby. I managed to find all but one of them and returned them roughly to where they belonged. I then blobbed some no-clean flux and a tiny bit of solder paste on the board, and tried to position the new regulator that I’d ordered. It took a few attempts and it still looked a little wonky to me when I left it. But I tried powering it on and the projector booted up, straight back to fully working.

Pics

Block Image

Block Image

Tips

  • If you’re new to soldering SMD components, be wary that its flipping hard if you’re a complete novice
  • Be super wary of where you’re pointing your hot air tool as the temperatures needed to get the chip off were plenty hot enough to melt solder in the nearby area causing components to literally go sliding off the board
  • Take the best quality pictures you can of the area before you do any soldering, so you can return things to their correct place if things go wrong
  • Also finally and slightly unrelated - I stupidly didn’t realise the connectors for the ribbon cables for the optical engine were ZIF (zero insertion force) so I was ramming them into the connectors a couple of times before realising you’re supposed to flip up the back of the connector to release the ribbons. If you are able to get your projector powered on but the image is discoloured, you’ve probably not seated one of the three ribbons correctly, they’re quite finnicky but once seated properly you should see a correct image

Resources

Voltage injection (and this whole series actually): https://www.youtube.com/watch?v=EWuzmIz7...

Soldering SMD components with hot air: https://www.youtube.com/watch?v=rgcupYOn...

The chip you need to order: https://www.mouser.co.uk/ProductDetail/5...

P.S: If you’re UK based, I have a spare one of these chips so can send it you out a bit quicker than waiting for it to arrive from Texas.

Was dit antwoord nuttig?

Score 5

3 opmerkingen:

Lol on some of the stupidity specially around ZIF....but you managed to get it back, that's awesome... I am not that expert either....I have all the tools ....will follow your troubleshooting steps and will let you know my findings.

Thank you very much for putting everything together, appreciate it.

door

This is very useful. Thank you for taking time to describe all this details. It happened mine is also not turning on and when I opened the board, the same chip you found is heating up too. I ordered for the chip from Texas and it arrived just after 4-5days. I have the projector opened with my soldering iron getting hot while i am an absolute novice on this.

door

Many thanks for posting this repair, saved me a lot of time in locating the fault. I have changed this chip on two projectors now ,an EB-U05 which is now fully working and an EH-TW650. The EH-TW650 now powers up but the lamp won't turn on, it powers up, fans are running, the status light and lamp lights flash for about two minutes, then it beeps twice and shuts down. According to the manual that combination of flashing LEDs says it's an internal fault. I have tried a known good lamp but no change. Anyone have any ideas? I've seen mention of the lamp ballast being a potential cause? Any suggestions welcome.

door

Voeg een opmerking toe

Please find picture attached where I have highlighted 12v reading on my multimeter

Block Image

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Hi David, you are right, I think it's my luck I found your post. I followed the steps you listed and it's the same regulator heating up for me as well. Please find the picture, yes next big task is to get it replaced

Block Image

How do I contact you? It would really help if I could buy it from you rather than waiting for 8 weeks.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

David Higginson zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 2

Afgelopen 7 dagen: 24

Afgelopen 30 dagen: 137

Altijd: 5,108