Ga door naar hoofdinhoud

Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7, ID iMac11,3

362 Vragen Bekijk alle

Internal Bluetooth Problem - Bluetooth "No information found."

I have a bluetooth problem on my iMac 2010 27”.

Tried SMC, PRAM and even replaced the whole Bluetooth card, antenna and cable.

Reinstalled MacOS high Sierra (erased and then fresh install), also tried removing the plist files.

Under Bluetooth explorer, I get the following in event log when I try to open Bluetooth set up assistant. Anyone seen this and been able to resolve it?

Process: Bluetooth Explorer 4.4.0

Operating System: Version 10.13.6 (Build 17G66)

Date: 2021-01-03 14:06:08 +0000

Initializing Bluetooth...

Bluetooth Support Initialization complete.

updateChainPower error: -3900

2021-01-03 14:06:49 +0000 Apple80211Get(APPLE80211_IOC_BTCOEX_MODE) returned error -3903

updateChainPower error: -3900

Jan  3 14:12:24 imacs-iMac com.apple.xpc.launchd[1] (com.apple.xpc.launchd.domain.user.501): Service "com.apple.xpc.launchd.oneshot.0x10000003.Bluetooth Setup Assistant" tried to register for endpoint "com.apple.btsa" already registered by owner: com.apple.btsa

Jan  3 14:12:24 imacs-iMac com.apple.xpc.launchd[1] (com.apple.updateEFIDesktopPicture-apfs[536]): Service exited with abnormal code: 1

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

Sounds like the feed to the Bluetooth board from the logic board is having issues!

I would first trace out the continuity of the cable from the logic board connector to the BT board connector to make sure its not a simple connection issue.

Block Image

If you’ve already done that then that starts to get into repairing the logic board. So here’s a snippet of the area we are working on. I would check external USB Ports to see if they are working as that could offer a clue if the issue is the hub chip or the feed to it.

Block Image

And here’s the full breakdown of the logic

Block Image

You’ll need to probe the voltages to see what failed

Was dit antwoord nuttig?

Score 1

Commentaar:

Thanks Dan. I will check it out, just as you were responding I was going to update the original post to say USB port 2 and 4 are not working either.

door

@faisalgondal - Kismet! Thats not good ;-{

The hub chip has likely failed then. You could try touching up the solder joints to see if one of them was cracked or cold.

door

Hmm, where on the logic board am I looking in particular for the USB hub? Is that U3600 as above? I checked the joints around Bluetooth cable connector earlier when I had the board out and it seemed ok.

door

@faisalgondal - I don't have a boardview for this logic board so I can't point you to the U3600 chips location.

But! You should be able to find it looking at the boards markings! You are looking for two QFN chips (9 pins per side) which are likely near each other. Then locate the two inductors L3629 & L3658 as they will also ID which chip is Hub-2.

door

Brilliant, will check it out tonight and feedback

door

2 commentaren meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

Faisal Gondal zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 6

Afgelopen 30 dagen: 17

Altijd: 293