Ga door naar hoofdinhoud

Support and repair information for Marantz home theater AV receivers and older audio-only receivers.

47 Vragen Bekijk alle

Marantz SR6013 Amplifier Circuit Failed

I’ve removed all connections, plugged into a different outlet, reset to factory defaults, re-initialized it, and I’m still going directly into the power indicator flashes red every 0.5 seconds. So I’m pretty sure it’s the Amp Circuit in some way…

It’s out of warranty (90 day refurbished warranty was up in June 2019)

Hoping to fix it myself as I paid $2k for this thing and I’m really !#^&@@ off right now that this has happened.

Does anyone have any advice on what to look for inside the receiver? I’m hoping it’s just a blown capacitor I can replace but I’m not sure where to look first and what to see if there is something noticable.

Thank you for any help or advice,

CJ

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

with the cover off you will note the 2 boards together on 2 heat sinks , there are 3 5 pin connectors 4 black 1 rad wire disconnect 1 at a time and try to power up if it duz the one you disconnected is the bad amp channel , if still shuts down on the other side of the amp closes to front of unit, there is 2 more 5 pin connectors 4 black 1 white wire this time , same as before disconnect one at a time and power up, if it stays on you have found the blown channel. you would then need to remove the board and replace resisters and transistors in that one section.

Was dit antwoord nuttig?

Score 1

9 opmerkingen:

BY GOODNESS IT WORKED. so i was able to troubleshoot and identify the issue, disconnect it and the amp is currently up and running. now what I need is the part number for the entire amp circuit or a rebuilt capacitor kit to fix myself. For my unit's failure, issue was the 5 pin (1 red, 4 black) connector on the left of the middle amp circuit with the attached heatsink.

door

@wolfpup6 THX. this got me directly to the failure in my SR6013. now gotta figure out how to fix it.

door

This was helpful because I was able to unplug all 5 of those connectors, and it stays powered on. A soon as one is plugged back in, powers off again. Any thoughts from there?

door

@seannaples

Are you talking about the speaker connections on the rear panel.?

If so does it always happen when you plug the same one back in or any one of them?

door

No, I’m talking about the internal 5 pin connectors, that Wolfpup mentioned.

With all 5 unplugged from the board it powers up, and I’m able to use my pre-outs to at least have stereo while I figure this out.

If I plug any of those internal 5 pin connectors, on the boards with the heat sinks, it will immediately turn off again.

Not a great picture but it’s roughly these locations, for those internal connections.

https://imgur.com/a/PfP9ilk

door

4 commentaren meer tonen

Voeg een opmerking toe
Het nuttigste antwoord

Hi,

Assuming that you have done the first two checks as shown in the owner manual for a Power turns off and the power indicator flashes in red approx. every 0.5 seconds problem, then as you say there is a problem with the amp circuit.

a). Check the speaker connections. The protection circuit may have been activated because speaker cable core wires came in contact with each other or a core wire was disconnected from the connector and came in contact with the rear panel of this unit. After unplugging the power cord, take corrective action such as firmly re-twisting the core wire or taking care of the connector, and then reconnect the wire. (v p. 37)

b). Turn down the volume and turn on the power again. (v p. 84)

c). This unit’s amplifier circuit has failed.

If there is nothing obvious on the amp board e.g. heat stressed or blown components etc you may have to spend a bit more and get the service manual. I can’t find a free one online, you may have better luck. Having this will definitely speed up the process of locating the problem, i.e. it has full schematics and also shows the protection diagrams etc.

There are other suppliers online that may suit you better. Just search for Marantz SR6013 service manual to get results.

Hopefully a start

Was dit antwoord nuttig?

Score 2

1 Opmerking:

Thanks and yes, I did all the other checks as well as some random suggestions I found on Reddit. All of which result in the same error happening. Next steps are gonna be looking for obvious issues with the amp board (first figuring out which part that is lol). Thanks for the info on the Service Manual, I'll see what I can find.

door

Voeg een opmerking toe

Voeg je antwoord toe

Cortney Sauk zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 4

Afgelopen 7 dagen: 30

Afgelopen 30 dagen: 97

Altijd: 1,823