Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

Model A1297 Unibody: Early 2009, Mid 2009, Mid 2010, Early 2011 & Late 2011

622 Vragen Bekijk alle

MBP 2011 Detects Battery but won't charge or run from it

I've got a Late 2011 17" i7 MBP which i've acquired as it was marked as dead and destined for the bin. I dont know how long it's been sat 'dead', but i'd guess at at least 4 years or so.


After a bit of googling and looking through the forums, i determined it was the DC-IN board that had failed. The replacement was P/N 820-6525-A (I think it was) which isn't the exact same P/N as the one that I took out, but apparently they are compatible, and it was more readily available.

Anyway, fitted the new board, and the MBP fired up and all seemed well.


Only issue i could notice was it was charging slowly - but put this down to the fact the battery had probably been empty for a few years.


So, left it most of the day yesterday charging and it got to about 70%. I switched off the charger overnight and while at work today as didnt want to leave it unattended.

For info, the battery shows only 89 cycles from new, with a 95% of new capacity and said good health.

Came to it today, and turned the charger on and left it for an hour or so. Came back to it and it showed fully charged (green light on MagSafe) - which seems quicker than it was charging yesterday.


Unplugged charger, turned on the MBP. It got to about 80% of the loading bar and then died and wouldn't turn on again. Have now plugged the charger back in and it boots okay, and shows battery 81% charged, but says "replace now" and "battery is not charging".


Have tried resetting SMC, disconnecting and reconnecting battery, etc, but battery now appears to be dead. If i press the battery test button (with MagSafe plugged in), all 5 lights flash. If i press it with the battery disconnected (and MagSafe plugged in), again all 5 lights flash. If I press it with magsafe unplugged so its just on battery, there is nothing whatsoever.


Is it that i was just unlucky and the first bit of stress on the battery for probably about 4 years has killed it, despite seeming okay, or is something else possibly giving issues?


Any thoughts, suggestions, etc very much appreciated.


Sorry for long waffle - just wanted to give as many details as possible. Many thanks.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

First use a better diagnostic tool. Install Coconut Battery and post your results.

https://coconut-flavour.com/coconutbatte...

Was dit antwoord nuttig?

Score 1

Commentaar:

Thanks. I will get a full set of info later, but from memory, the results were all pretty good in terms of battery capacity.

95% of design capacity.

89 cycles.

Think then battery health is poor. And charging with 0 Watts. Running off of power adaptor.

Prior to it crashing, the battery health was showing good.

door

Voeg een opmerking toe

The battery must be faulty.

I would not be surprised if the battery module had faulted out.

Was dit antwoord nuttig?

Score 0

Commentaar:

Thanks. Is there a way to test it before I shell out on a new one? Multimeter etc?

door

Or can I try a different battery. I have a 2010 15" MBP also. I know the plugs are slightly different but would the pinouts be the same?

door

Voeg een opmerking toe

Voeg je antwoord toe

Mike B zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 1

Altijd: 38