Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie


Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

942 Vragen Bekijk alle

Why Can't I upgrade my 2010 MacBook Pro to 16gb?

I have a mid 2010 13” MacBook Pro. 2.4GHz Core 2 Duo, running High Sierra 10.13.6.

  • Boot Rom
  • SMC 1.62f7

I recently purchased a RAM upgrade 8 GB x2 SO-DIMMs to get to 16 GB (1066 MHz).

But when I install them my Mac won’t start up. If I use the stock 2 GB memory it starts just fine.

I have tried every combination of sticks and slots, but it will only work at the max of 10 GB. Please help.

Update (06/18/2019)

Model Identifier is MacBookPro7,1 the other numbers are in the original post.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 3


Curious if you got anywhere with this. I have basically the same issues (Boot ROM is the only difference), and I would love to figure out how to get the EFI update to work.

2x4GB DIMMs have worked fine for years. 2x8GB doesn’t. I may try to mix and see if I can get to 12GB.


12GB worked, but I could never get 2x8GB working. I bought chips from a different vendor and those worked perfectly. *shrug*


+1 to Steve. See comment on guide:

MacBook Pro 13" Unibody Mid 2010 RAM Replacement


Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

Could be a bad slot or your EFI didn’t get upgraded. Go “about this Mac” memory and see what each slot is reading. It looks like it is reading one as 8 GB and the other as 2. Remove the stick that is reading as 8 and reboot with just the one remaining stick still in it and tell us what it reads.


Use these steps to check your Mac's EFI Boot ROM and SMC firmware versions.

  1. Open System Information. Apple Menu > About this Mac > Overview > System report.
  2. Select the Hardware section to view the Model Identifier, Boot ROM version, and SMC version numbers.
  3. MacBook Pro (13-inch, Mid 2010)MacBookPro7,1MBP71.0039.B0E (EFI 2.5)1.62f7 (SMC 1.6)

Was dit antwoord nuttig?

Score 4


It reads both slots properly. If I swap the 8gb and the 2gb it will read them properly is each slot. If it restart it with either of the 8gb it reads them both properly in either slot.

The problem occurs when I try to run both 8gb together.


Neither of those updates are supported because I am running High Sierra and I cannot upgrade to Mojave, because the video card does not support "Metal"


My Boot Rom doesn't even start with MBP


MBP stands for Mac Book Pro. The Boot ROM is 71.0039. You are running 66. You did not do your system updates incrementally so you missed the EFI updates.


Any other suggestions?


6 commentaren meer tonen

Voeg een opmerking toe

I had these same symptoms on my machine. See comment on guide:

MacBook Pro 13" Unibody Mid 2010 RAM Replacement

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Voeg je antwoord toe

Lucas Pinckard zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 6

Afgelopen 30 dagen: 23

Altijd: 1,676