Ga door naar hoofdinhoud

The first Android smartphone from Google, the Pixel XL (Model Number: G-2PW2100) was launched October 20, 2016. It has a 5.5-inch AMOLED display, 3450 mAh battery, and 32 or 128 GB storage options.

67 Vragen Bekijk alle

Pixel XL WON'T Charge/Connect to PC

I decided to do Teardown & Reassembly  of my Perfectly working (OLD & beat up) Pixel XL.  After Reassembly  everything WORKS except it WON'T Charge or Connect to PC. It appears that the USB Port at the bottom is DEAD, Anything connected to it ( AC charger or USB to computer) WON’T do anything to the phone.when i connect it to computer i get No Notifications on the phone.  Replacing  the bottom charge Connector board  did NOT help me. What went WRONG any suggestions?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
3 opmerkingen

Thanks for your quick Reply.

NO changing to a known Working Ribbon cable DIDN’T fix my problem. and there is No damage to any of the 4 Connectors (2 on the Ribbon cable and One each on the Dock Connector & Logic Board). Since the ribbon is the only one that connects two areas of the phone, so something went bad during reconnecting.the ribbon cable is BARELY long enough to be able to position right on top of the connector once we connect one side of it. So i think one end of the connector didn’t seat Perfectly and Shorted/burned the USB Controller (or whatever) thats on the logic board side) because changing the dock connector board is NOT fixing the phone. So whatever is causing this issue is on the Main board. I think its history. I will update the forum if i find a Working Solution. Hoping for the Best.


Mines intermittent ,I've taken it apart to replace the port and it worked for about 10 mins and stopped. i've also let it charge without the mid-frame in and it works perfectly but as soon as I put the mid-frame in it either doesn't work at all or for about 10 minutes.


This is easy to solve. When you press the mid frame into position it is causing some unnecessary contact giving you the problem. most likely the dock board is not seated correctly. If you think the dock board is seated correctly then cover the underside of the mid frame that is directly above the whole of dock board with some thin tape/paper and see what happens.


Voeg een opmerking toe

1 Antwoord

Het nuttigste antwoord

Maybe perhaps the ribbon cable connecting from the dock to the logic board has gone bad? Have you inspected connector on both sides for any signs of physical damage?

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

Did the new cable work? I'm having the same issue.


HAPPY to report a second NEW cable WORKED. Don’t know what went wrong with my Original cable or the first NEW replacement. So it was the cable that went bad or NOT seated Properly( Hard to believe cause i took all the proper CARE.).

Thanks for all the help


Voeg een opmerking toe

Voeg je antwoord toe

Google USER zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 0

Altijd: 129