Ga door naar hoofdinhoud

Released September 16, 2016. Models A1661, A1784, and A1785. Available in 32, 128, or 256 GB configurations in Rose gold, gold, silver, black, jet black, and (Product)Red.

741 Vragen Bekijk alle

Require technical advice on what may be broken (iPhone 7 Plus)

Hi guys

I have a friend who not long ago accidentally shut the van's door on his beloved iPhone 7 Plus, and well...++this was the end-result.++ (Keep in mind it was fully functional however)

I offered my help to attempt fixing it as I knew parts are really cheap nowadays on eBay and I diss/assembled a few phones before. I am nowhere near precise or professional, I only do it to save myself a lot of money and for my friends.

Now, I've bought a new screen, a new rear housing and put everything back together. It all looked good and all, however when I connected the lower board's cable to the main motherboard (which I believe is connecting the lower board to the main one), the bottom board does not seem to get any power, hence when it's all connected together, the phone wouldn't ever boot up. Strangely, when the cable isn't connected, the phone boots up, however from my testing: the charging port doesn't work, neither the vibration motor. With that in mind, I assume that neither the microphone, speaker work also as they do not get power and aren't fully connected to the main board.

This is ++the original one++.

++A few more images++

So, I thought that I might have screwed something up and damaged the bottom board, so purchased a new one. A few days later, I disassembled and put the iPhone back together, only to find out that the brand new, undamaged lower board is affected by the same issue. It doesn't charge, nor it has any haptic feedback - and assuming the speaker and the microphone also do not work.

So here I am, a few days later. I've looked everywhere on Google to see if others had a similar problem, but found absolutely nothing. Would anyone perhaps be able to point out a few things on what I should search/look for, perhaps experienced the same? Any advice would be much appreciated.

If nothing works out, I will either take it to a repair shop and see if they can figure it out, or sell it for scrap parts. (My friend has neither warranty, insurance or AppleCare, so taking it back to Apple - especially after I've changed the whole housing is not an option)

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Een opmerking toevoegen

iPhone Batterij Fix Kits

Slechts $29.99

Buy Now

iPhone Batterij Fix Kits

Slechts $29.99

Buy Now

1 Antwoord

Gekozen oplossing

Ouch!

My original thought was that you may have a defective replacement part. However, the chances that you have two defective replacement parts is much lower. However, given that there are so many variables here, it’s hard to pinpoint the issue. It could be housing related, it could be parts related or it could be logic board damage as the phone was really put through the grinder.

Did the phone work properly after the bend but before the massive repair attempt? Ideally, you need to find a point in time where everything worked (or mostly) and then trace your steps through the process.

One thing you can do is remove everything and connect only the Lightning Port Flex and battery to the logic board, while out of the housing. See if the Phone boots and charges and then progressively add flexes.

Was dit antwoord nuttig?

Score 3

Commentaar:

I had the same thought, but it's just really hard to believe that I would have a brand new part broken and non-functioning. (of course, there's a possibility)

The phone surprisingly worked perfectly even while it was in its original condition: camera worked, speaker worked etc. I was pretty amazed that nothing other than a few holding brackets got damaged on the top that I of course couldn't save.

When I put it all together (including the lower board connected - lighting port flex cable) it would get stuck on the Apple logo. When the flex cable was disconnected, the phone did boot up and everything seem to work, except the charging port, speaker, taptic engine and assuming the microphone.

I'm sure this is hard to pinpoint, I'm mostly only just looking for suggestions as at this point, I really have no idea on what I could have possibly damage, or what could be damaged.

Luckily I didn't put the adhesive back under the battery yet, so I'll give that a try. Thank you for the suggestion.

door

Okay, so I sort of gave it a try. (10/10 would not approve what I just did, most likely, but it's the most efficient way for me to test it out, so I take it)

I've connected the original flex cable while leaving everything intact and surprise, it started charging. I think it's the connector on the new Flex cable that might be the one to blame, so I will take it apart tomorrow and assemble it together, with the old flex cable. Before I do that, I'll see if I can attempt to fix the new one.

It's strange, it would not ever charge before (after I changed the housing and put it all back together)

https://imgur.com/a/iH4OHVo

door

They can be tricky to connect, the flex needs to be really square with the connector to get it to seat correctly, if its not then you get the issues you describe.

door

Een opmerking toevoegen

Voeg je antwoord toe

Roland zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 2

Afgelopen 30 Dagen: 4

Altijd: 73