Ga door naar hoofdinhoud

2.26 or 2.4 GHz / White plastic unibody enclosure

703 Vragen Bekijk alle

Why does MacBook Mid-2009 lose data and time?

My Macbook Mid-2009 El Capitan loses date and time when I unplug it from AC power. And when I boot up, there’s a delay of about 5 seconds between when I press the power button and I hear the boot chime.

It seems the classic symptoms of a problematic PRAM battery, but when I looked in the guides for how to change the PRAM battery, I found out that this model doesn’t have one!

I’ve tried resetting PRAM and SMC.

The computer works fine once booted.

Ideas?

Update (01/05/2019)

Okay. Here are the pics.

Block Image

Block Image

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2

Commentaar:

Lets get a bit more info on your systems battery. Install this gem of an app: CoconutBattery take a snapshot of the main window with the MagSafe connected and a second disconnected. Paste both here for us to see Adding images to an existing question

door

Een opmerking toevoegen

Android Fix Kits

A new screen or battery is one kit away.

Nu winkelen

Android Fix Kits

A new screen or battery is one kit away.

Nu winkelen

1 Antwoord

Het nuttigste antwoord

The charging logic does appear to have an issue as it charging at only .12 Watts which is way too low given the batteries charge state. I’m thinking the SMC has some corrosion around it. You’ll need to pull the logic board and inspect it for damage. MacBook Unibody Model A1342 Logic Board Replacement. You may need a new logic board.

Was dit antwoord nuttig?

Score 1

Commentaar:

OK thanks.

I have been recharging the battery and noticed that it’s really slow. It went from about 50% to 70% over several hours.

Do you think it might be the Magsafe connection on the logic board?

If so, is it possible to replace just the connector, rather than the whole logic board?

door

Review this Apple T/N Apple Portables: Troubleshooting MagSafe adapters to make sure the adapter is in good shape as well as the connector.

I still suspect your SMC logic on the back side of the logic board is in trouble given what I'm seeing here.

door

Een opmerking toevoegen

Voeg je antwoord toe

Matt zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 0

Afgelopen 30 Dagen: 0

Altijd: 66