Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie


The larger of Apple's MacBook Air laptops featuring dual microphones and 802.11ac Wi-Fi connectivity.

434 Vragen Bekijk alle

Can't erase disk, nothing is working

I have a computer that I securely erased the SSD with Parted Magic.

I booted to the Mojave installer and went to diskutil to erase (reformat) the drive to prep for install. The SSD was not showing up.

So I went into the terminal and found the SSD via command “diskutil list”, it appeared at the bottom of the list as disk20, which I thought was weird because it is generally disk0.

I used terminal to erase the SSD for install: “diskutil eraseDisk JHFS+ Macintosh\ HD disk20”

The process got stuck on erasing at 50% and did this for a whole day.

I am very confused, at this point I’ve tried:

·         Using different bootable installer (high sierra, sierra, elcap)

·         SMC and PRAM resets

·         removing battery

·         using a different SSD (…so it is the computer not the drive)

·         And simply just trying multiple times

I am at a loss, any ideas guys?

Thanks in advance for the help!

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

1 Antwoord

Does Parted Magic format APFS? Why did you use it instead of Apples Disk Utility? Why the secure erase?

Was dit antwoord nuttig?

Score 0


Parted magic formats the drive to NTFS, but I have never ran into this issue using Parted magic.

I always just reformat the drive back to APFS or JHFS.

The reason I use Parted Magic is because I work in a facility where data security is our number one priority.

We fix University machines and sell them to the public.

Apples disk utility doesn't actually securly erase SSD's.


Since you're a Professional, I would invest (and I have) in all the different OWC Envoy external enclosures, so you can work with these Apple SSD blades. Try this one: OWC Envoy Pro Portable, Bus-Powered USB 3.0 Enclosure for Apple Flash SSDs, (OWCMAU3ENPRPCI)

I get them cheaper because I order them with the upgrades.


I do have something similar to this, for most of apples funky proprietary SSD's.

I usually have trouble booting parted magic on MacBook’s while trying to erase the drive in the machine, so I usually pull them, use the adapter, and wipe them in a PC.

I forgot to mention that I did this for both SSD's I tried in this machine.

Not really sure what the heck is going on here!


Voeg een opmerking toe

Voeg je antwoord toe

Taylor Struna zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 0

Altijd: 68