Ga door naar hoofdinhoud

The Ford Explorer and the Mercury Mountaineer were both updated for the 2006 model year on a new frame, produced by Magna International rather than Tower Automotive.

25 Vragen Bekijk alle

My 2007 explorer rear wiper issue not working

  1. My rear wiper motor won’t work I swapped out 2 other rear wipers motors and still can’t get it to work would it be the wiper switch the front work with switch but only can get the fluid to spray back window but not the wipers to work…anyone got a suggestion
Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

Hi,

Have you checked that fuse #12 in the passenger compartment fuse panel is OK, you didn’t say?

Was dit antwoord nuttig?

Score 2

2 opmerkingen:

Yes I checked all fuses I do get a faint click noise when I try to turn on rear wiper

door

Where is the fuse compartment in the passenger side bc I dont get anything but fluid when I try to use my rear wiper

door

Voeg een opmerking toe

Hi @Earl Mullins,

The passenger compartment fuse panel is in the passenger compartment on the driver’s side.

There isn’t a fuse panel on the passenger’s side of the passenger compartment

Here’s an image taken from the 2007 Ford Explorer owner guide (p.281-282) showing the location of the passenger compartment fuse panel and the fuse location in the panel and its’ functions

Block Image

(click on image to enlarge for better viewing)

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Voeg je antwoord toe

jamie33kenney zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 8

Afgelopen 30 dagen: 43

Altijd: 3,078