Released September 22, 2017. Model A1863, A1905. Available as GSM or CDMA / 64 or 256 GB / gold, silver, and space gray.

118 Vragen Bekijk alle

Battery percentage stuck at 1%

After replacing the iPhone 8 display, the battery percentage shows 1% and its not charging at all. I tried the following but none fixed the problem:

1) Wireless charger and several different wired chargers with different cables but no chance.

2) I am sure the charging port is fine since iTune recognizes the phone via USB connection.

3) Hard reset didn't help

4) iOS Update didn't (11.3.1)

5) Put the original broken display back on, still not charging.

I was wondering if anyone experienced this problem and found the solution ?

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

3 Antwoorden

Gekozen oplossing

I don’t have pictures but have seen this before: there is a small component near the battery connector in the iPhone 8 that constantly gets knocked off during repair, leading to this failure.

It is an easy fix for a good microsoldering technician.

Was dit antwoord nuttig?

Score 5

Commentaar:

Thanks Rany, I checked the phone in my rework lab with microscope and you are right that chip is missing and unfortunately for some reason my ZXW is not working at the moment to find out what it is, hence I was wondering if you know what the component is ?

door

Umm, I am sick with bronchitis, not at the lab.

Besides there is no iPhone 8 on ZXW yet IIRC.

Your best bet is to look at a good board or ask someone who has a good board to measure it for you. I think there is something stupid like a resistor on the gate line? Not sure anymore.

door

I contacted everyone but no chance to find iP8 component schematic but finally a colleague from UK sent me the chip specification which is classified as a "ROHM Semiconductor".... I better not to mention the part no. at this stage to prevent confusion till I receive it and try it then I will share the details.

door

its fixed, the chip is RV3C002UN, It took me a while because couple of pads were gone too.

door

Bezad where you got this chip from. Looks like am stuck in same position as well

door

7 commentaren meer tonen

Een opmerking toevoegen

Did you try reseating the battery cable?

It can sometimes be as simple as that as I've had a few cases where the battery ribbon cable got partially disconnected when removing the metal shield that also covers the screen cables.

Was dit antwoord nuttig?

Score 1

Commentaar:

Thanks Ben for the tip, unfortunately it wasn't the the battery ribbon but a little damage to the PCB close to battery terminal which "Rany" addressed.... I am working on the logic-board and when its fixed I will share the information.

door

Een opmerking toevoegen

Hey @bezad53, did you ever end up snapping a picture of where the component was on the board? I have the same issue and have ordered the component listed above - just want to verify that I'm looking in the right place.

I have a pic of the logic board if you could indicate where you did your repair. Thanks!

Pic:

Block Image

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

Bezad zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 50

Afgelopen 7 Dagen: 340

Afgelopen 30 Dagen: 1,366

Altijd: 7,670