Ga door naar hoofdinhoud

Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus. Identifiable by the model numbers A1549, A1586, and A1589.

5198 Vragen Bekijk alle

No backlight, black screen. Image visible with torch.


My iPhone 6 started intermittently suffering no backlight, although the phone still worked and the springboard could just about be seen with a torch shone on the screen.

The backlight would randomly work when I took the phone out of my pocket and pressed the home button, and that intermittent state lasted a few days.

The fault then became permanent.

I’ve checked the backlight inductor and diode. Inductor looks okay with no overheating and reads short as it should. The diode measures infinity in one direction, volt drop of about 0.6 in the other, so is reading normally for a diode.

All fusible links (FL****) are reading short. FL2024 is reading a constant voltage of 3.8v (battery voltage) instead of the higher voltage expected.

I’ve got schematics and board layouts with pin connections, but without a circuit description I don’t know what starts U1502 switching and producing the higher anode voltage.

Has anybody come across this fault with the above readings? Is it likely to be U1502 backlight driver IC, or is chestnut U1501 display IC implicated?

I’d rather not change U1502 if not necessary because of expense and the original being surrounded by hard epoxy that’s spread from the CPU, which is also around the inductor and diode.

This phone has never got wet. The fault started out of the blue.


Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1


Have you tried to replace the battery for the boot looping?


Yes, tried a known good battery (I have another iPhone 6 that works except for constantly showing “no signal”).

Replaced Tristar.

I can disconnect the battery and connect a charging lead and it’ll go into the same boot loop.

Tried it with front camera/sensor flex disconnected.

It’s annoying because the last AliExpress-sourced U1502 I fitted did get the backlight working but only half of it, as the chip had one of the LED return lines shorted, but the phone still booted and worked.

Maybe yet more heat fitting the latest U1502 has damaged something? Not sure where to start fault finding.


I’ve now found I can get the phone to boot normally and work for a few minutes by applying some heat with my hot-air station to the A8 cpu. After those few minutes, it goes off and then loops on the Apple logo again.

Any ideas?


Voeg een opmerking toe

1 Antwoord

Gekozen oplossing

U1502 backlight IC was the culprit. Went through five of them from AliExpress which were all faulty, so beware. Bought one from a UK repair centre on eBay that uses the supplied ICs in their own repairs and it fixed the backlight.

However, the phone now loops on the Apple logo continuously. I have no idea why. I’ve just changed Tristar but it’s still looping.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

jamesqb2001 zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 2

Altijd: 329