Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

This tablet was released by Asus on July 2013. The model is also called ME173X. The tablet features a 7 in. display microSD card slot, a MicroUSB slot, and a headphone jack.

30 Vragen Bekijk alle

ASUS Memo Pad 7 won't charge

I currently have an Asus Memo Pad 7 that won't charge. I've tried replacing the cord and that doesn't do anything. At one point the tablet finally came back on for about a second and showed the empty battery icon then shut off. I'm thinking that it may be the battery and that I'll need a new one. Any thoughts on how to fix it? Thanks.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

If you can, take out the battery, then plug in your charger.

I could be wrong but that will directly power the tablet, then it should come on.

If it works, then its a battery problem, if it doesn't work, it could still be a battery problem as Im not sure if that will work.

You most likely just need to buy a replacement battery for the tablet!

Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

Have you tried jumping it with a power supply?? or what volts is the battery reading when you test the leads?

If the battery is reading zero you may need to jump it then check the voltage again.

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Voeg je antwoord toe

Peyton zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 3

Altijd: 809