Ga door naar hoofdinhoud

2.4GHz, 2.7GHz, or 2.8GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache. Released February 2013.

263 Vragen Bekijk alle

MacBook doesn’t recognize new hard drive

I’ve tried 2 different hard drives in my MacBook after I had problems with the original.

When I boot to the USB, disk utility doesn’t see the new hard drive. If I put the old one back in, it will recognize it, but it fails out when I try to format it.

I’m hesitant to blame the hard drives since I’ve now tried 2, but I can’t think of another potential cause.


Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
4 opmerkingen

The retina models use a solid state drive (SSD) not a traditional spinning disk hard drive (HDD). Are you sure you have a Retina model?

Who's drive are you using? Please tell us the make and model.


Yes, it's an SSD made by OWC specifically for this computer. It's an OWC Aura 6gb/s SATAIII. The 2012-early 13 MacBooks have a hard drive that it unique to them and according to the website, this is the one that works.


OK, Just so we're clear here you have an Early 2012 13" MacBook Pro not a 13" or 15" MacBook Pro Retina model. Is that correct now.

This is the non-retina model SSD from OWC: MacBook Pro 13" & 15" 2012 (Non-Retina)

This is the Retina model SSD from OWC: MacBook Pro with Retina 13" & 15" 2012 — Early 2013

If you can point us to the unit you bought that would help as well here.

I just want to be sure we are on the same page, as you've mixed terms and have stated different systems. Clarity & consistency helps so we get you aimed correctly.


Dan, thanks for helping. The computer is the retina model I posted the question under, and the drive is the correct one for that model. Here's the link to what I bought:

OWC 240GB Aura 6G Solid-State Drive for 2012-2013 MacBook Pro with Retina display.


Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

I found the answer thanks to OWC's very helpful tech support.

The drive needed to be formatted for Disk Utility to see it, so I did that through the terminal and it worked great.

It didn't make sense to me that Disk Utility wouldn't see the drive, and that //diskutil list disks// would, but there it is.

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe
Het nuttigste antwoord

OK, I think I figured out the problem here! 2013 was a transitional year. For reference here's the three models produced that year:

If you open each of these links and jump down to the 'Storage Dimensions:' line you'll see the early model offers a custom 6 Gb/s mSATA interface, whereas the other two offer a custom PCIe 2.0 x2 interface.

I'm suspecting you really have one of the late 2013 models which is why the SSD you got won't work.

Was dit antwoord nuttig?

Score 1

1 Opmerking:

It's definitely an early 2013. I checked the serial number, and the PCIe interface physically is much different. A PCIe drive would not fit where the drive in this computer goes.


Voeg een opmerking toe

Voeg je antwoord toe

Mike Stone zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 2

Afgelopen 30 dagen: 13

Altijd: 4,567