Ga door naar hoofdinhoud

2.4GHz, 2.7GHz, or 2.8GHz quad-core Intel Core i7 processor (Turbo Boost up to 3.8GHz) with 6MB shared L3 cache. Released February 2013.

263 Vragen Bekijk alle

Can't get baterry to charge, what's next...

Replaced battery and the MBP worked flawlessly BUT can't get it to charge, so I replaced the DC power jack but still no luck.

Of course I've tried several chargers before.

(Now I think the original battery and the original DC power jack were just fine)

What's next for me to do? Something in the logic board... some kind of workaround? because everything works, just can't send charging to the battery, so when it drains, it's goodbye



Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
2 opmerkingen

Did you try a PRAM reset after the replacement? Since the battery in this device is glued and difficult to remove, are you sure you did not knocked of something on the motherboard in the process?


Hi Oros, thanks for your answer. It all worked perfectly after I installed the new battery... till it was out of juice, the brand new battery that is.


Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

Before any repair, please understand that attempting your own repair is ones own personal choice, and though we give you the means to do a repair, we are not responsible for any personal injury, or damage to property that may occur in doing so. Please be aware, that without the proper tools, including an ESD Mat/Bracelet, extra damage may occur. Electro static discharge is very real, and very common.

there is an easy way to test the DC power jack.

Disconnect it from the board, while leaving it plugged in to the adapter, and run a multimeter across the + and - Trace to read the voltage, and make sure it is the same output as the output of your Adapter. if it does, the part is fine.

Run a 5V power supply across the + and - leads of the battery, and see if you get an amperage. if you do, your battery should work as well.

If the above reads true, then YES, you are looking at a board issue. there could be physical damage from the replacement, or a short on the board could have easily caused components to blow. The device could have overheated, and caused a component to crack from the expansion, or there could have been ESD from not working in a dedicated tech workspace.

unfortunately, the process for board work requires a highly dedicated skillset, and a specific set of tools that cost nearly as much as a new laptop. so in this case, i would suggest cutting your losses, and getting a new device.

Was dit antwoord nuttig?

Score 0

1 Opmerking:

Thanks for your detailed (and quick!) answer... it seems is a board issue... since right after I replaced the battery I had a few full sessions, everything works, except I can't charge the battery... I was thinking maybe narrowing the issueto the "charging area of the board" ... :(


Voeg een opmerking toe

Sadly, there is no work-around. Your logic board needs repair ;-{

Now the big question is: Can you find someone near you who can repair it. Or, do you need to replace it, which you might be able to do your self.

Was dit antwoord nuttig?

Score 0

1 Opmerking:

Thanks for your answer... it feels bad to replace thw whole board, since it works perfect, just can't pass juice to the battery...


Voeg een opmerking toe

Voeg je antwoord toe

davidcantoni zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 2

Altijd: 92