Ga door naar hoofdinhoud

Nvidia's new iteration of the Shield Tablet line. Released in November 2015, this tablet is optimized for gaming and runs Android OS.

20 Vragen Bekijk alle

Why won't my Nvidia Shield K1 charge at all

Why won't my Nvidia Shield K1 charge. It is plugged in and not charging at all. Even when it would charge, the battery life was minimal.

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 6
1 Opmerking

Initially, the tablet was great but after having it for 16 months, I started having the same problem and paid $75 to have the port replaced at a computer service place. The tablet worked for about two weeks and the same thing happened again. As it was still under warranty, I took it back and was told not to use the tablet while charging it because the cord puts pressure on the port, and they fixed it again. The strange thing is I have always used my tablet while charging without any problem until recently. At any rate, the tablet worked fine for several weeks and the one and only time I used it while charging, it occurred again, :( I am going to take it back one more time, have it repaired (will not charge while using), and if it does not work, I will buy an Android tablet. This tablet is 18 months old, I am the only one using it, and the only thing I use it for is watching two shows nightly. For what my husband paid, I just do not believe I should have these issues.


Voeg een opmerking toe

2 Antwoorden

Het nuttigste antwoord

The most likely cause of your issue is a damaged Micro USB port. I have seen this issue from multiple different people including my own personal device. Insufficient support around the micro USB port allows for movement and subsequent damage to the port resulting in poor (if any) connection to the cable. I found that the only solution to this problem for myself, aside from replacing the port, was to put downward pressure on the cable (meaning push the cables connector away from the screen side of the device). This will work temporarily to charge the device. The only real solution I have found is to completely replace the micro USB port. Detailed instructions can be found here ( Nvidia Shield Tablet K1 Micro USB Port Replacement ). As for the short battery life, this is a direct result of the power and performance of the device itself and the need for a larger battery. You can thank Nvidia for that one (Lol). If you have rooted your device I would suggest using a kernel control app (I personally use the app "kernel auditor") to adjust the parameters of the CPU and GPU. If done correctly you can almost double the lifespan of a fully charged battery without any real noticeable loss in performance. Best of luck!!

Was dit antwoord nuttig?

Score 3
Voeg een opmerking toe

The iFixIt instructions for the NVIDIA Shield Tablet are flawed all the way through. Some of the end users’ comments are very useful and necessary to read before attempting to open this device.

The battery is so difficult to remove that it’s impotysny to have a replacement battery handy. You don’t want to mess with Lithium Polymer. Even with hot air to soften the glue and a lot of patience, it’s still very very difficult to remove.

You’ll need a hot air workstation to replace the USB connector. You will also need to have the replacement part. None of these are listed in the iFixIt article, which is the worst I’ve ever read.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

blitzwing2301 zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 4

Afgelopen 7 dagen: 8

Afgelopen 30 dagen: 32

Altijd: 11,757