Ga door naar hoofdinhoud

Yamaha YPT-300 61-key touch sensitive portable keyboard, released in 2005.

7 Vragen Bekijk alle

"E" key and 3rd black key is not working.

my Yamaha has 2 keys that are not working in every octave they are out. they are the "E" key and the 3rd. black key.. all the way across the board. Can someone tell me what's wrong?

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 5
5 opmerkingen

Same here but my keys are D and G#/Ab all the way across the board too. Can i still use the guide you give to the first problem?

door

Same here but my keys are c# and G in every octave

door

Having the same problem with my dgx-640 but with all the C and F# keys. HELP!

door

Very helpful BUT I have E#(pad 4)/ A (pad 10) /D# (pad 16) / A (pad 22) / A# (pad 47) / B (pad 48) / E (pad 53) / F (pad 54) / A# (pad 59) / B (pad 60) / C (pad 61) - all not sounding. Have cleaned rubber contacts and circuit boards (keypads) and re soldered all socket pins and cleaned the sockets all to no avail - problem persists - Where might this problem be? I have the full service manual.

door

all my E and B keys have no sound. I was able to use this forum to trace it back to the resistors to check the 3.3 V, but I do not know how. Could someone tell me how to check for the 3.3 DC V? much appreciated.

Also, I tried connecting the flat wire backward, but I still dont get sound from the E or B keys plus a few other. Is there something else I could check for thru the circuit? or how to check the flat wire is working properly? Thanks in advance!

door

Voeg een opmerking toe

8 Antwoorden

Gekozen oplossing

Hi,

Here is an image of the relevant part of the circuit which affects the E key. I think, not being a musician, that it also affects the "3rd" black key as well as they share the exact same wiring path up to the keys.

They are both 'powered' by the same 3.3V DC supply rail fed from 10K Resistor(s) R838 pins 5 and 7. This power feeds into the MicroProcessor (CPU) and also through the keyboard and back into the decoder.

The circuit path through to the keyboard is the most likely area of the problem as it passes through two connectors to get to the keyboard.

You need to check that the 3.3V DC is available at pins 5 & 7 of Resistor 838 on the DMLCD board and that the appropriate wires on the CN831 connector and CN1 connector are not loose and that the connectors are inserted properly, especially as the wires are at one end of the connectors so it might not be inserted 'straight'.

The circuit that you should test is from the DMLCD board Resistor 838 resistors pins 5 & 7 to connector CN831 wires 11&12 which go to 61H Board (on the keyboard itself) connector CN1 wires N24 & N14. From there it is multipled through all the E keys and 3rd black keys and then out to the decoder. The wiring to the decoder is 'shared' by the other notes so it is alright as they are working.

Block Image

Click on the image to enlarge for better viewing. Look on left of diagram, to the right of label DMLCD to find the R838 resistor stack then follow down through the connector to the connector directly below.

Here is the service manual for your Yamaha YPT-300 (also known as PRS E303).

This manual should assist you in the dismantling of your unit. Like all service manuals it has everything you need to know about your instrument.

When the sentence below the Document preview box changes from This file is downloadable free of charge:...processing to This file is downloadable free of charge: Get Manual, click on the Get Manual to download the file. Be patient it takes a few minutes to find the file.

Hopefully this is of some help.

Was dit antwoord nuttig?

Score 4

3 opmerkingen:

'I have the same problem but my keys are A and D# and I know is related to the flex ribbon. Does anyone know what the specs are for the 12 pin ribbon besides thke 12 pin so that I can order the correct part? the bad keys are only on the left side.'

door

@josemgz87 ,

If you have a Yamaha YPT 300 (aka PRS -E303) then download the service manual from the link above.

It has a complete parts list. Although searching for any part with "cable" in the title, using the part number gives no results of any use. You may have better luck as you know what you're looking for.

door

I was able to get the exact flat wire connectors for my Yamaha keyboard. The ones connecting the keys to the circuit board. Now it's working like new.

Thank you

door

Voeg een opmerking toe

Hi @keyboardman101,

You can use the manual but you’ll have to work out the circuit path from the reistor supplying the power for the notes (keys) in question.

If you click on the magnifying glass in the image above and then click on the enlarged image again you’ll get a better view of the keys and the musical notes that they are used for.

Download the manual using the link in the answer above and find the schematic which shows the keys as shown in the image above.

I don’t know music at all but when you find your key contact by its’ musical note designation, trace the wiring through the circuits back to a supply resistor on the DMLCD board. The wires are numbered to make it easier to follow through the circuit.

There will be a problem somewhere along this path, perhaps at the resistor or maybe a connector plug that is not quite pushed in properly.

The path will be different to what is described in the answer above because the notes are different in your case, but the principle of how they work is the same.

Good luck.

Was dit antwoord nuttig?

Score 2

1 Opmerking:

Can you help me with the same problem but on yamaha PSR-210?

door

Voeg een opmerking toe

Hi @hall_pass_please,

Here are some images taken from the service manual for the keyboard which may help to find the problem. The manual shows how to dis-assemble the keyboard so that access to the boards, connectors etc, is possible. Be patient if you go to download the manual as it takes a little while to go from processing to download, once you have passed the recaptcha test and clicked on go to download, below the document preview box.

The C and the F# notes share the same two wires through the keyboard keys and back to the DM processor board.

See the composite image below that shows the two wires where they leave the keys on the GHL88M board Connector 2 wires n16 and n26 to go to DM board Connector 6 wires n16 and n26 to get the power and also to connect to the CPU.

The n16 power feed is via resistor R102 and the n26 power feed is via R129 on the DM board.

You need to check that the +50V is on both resistors and that the connectors are plugged in securely and that the wires are terminated OK on the connector etc.

I have only shown the relevant sections of the circuit for the keys (notes? - I’m not musical at all) and also where the GHL88M is in relation to the other sections, but since the power leaves the DM board and then gets to the GHL88M board 1st before it multiples to the other boards/keys and as all the C and F# notes are affected these are the most likely trouble spots.

Hopefully a start.

Block Image

Block Image

(click on images to enlarge for better viewing)

Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

Hi @jaby,

I don’t know music so I’m not sure what keys (wires) you would need to look at. I only know how the notes appear as the notes or sharps and then what octave the particular note is and then work it out where the key is on the keyboard to find the wire.

Basically +3.3V is fed to the CPU on the control board and to the keys via a resistor and then a wiring / diode matrix and then when particular key(s) (if more than 1 key) are operated this voltage is fed back to the decoder on a particular wire(s) (if more than 1 key operated). This causes the CPU to detect a voltage change and also then the decoder knows which note needs to be played.

You would need to know the wires that the particular notes use (it may be common to several notes - that’s what the diodes are for - to separate the keys on the same wire) and then check that the +3.3V is being supplied via the resistor.

Here’s an image of the relevant part of the circuit diagram where I have highlighted the power for the keys (you can see the resistors there on the circuit) and where it goes to the CPU and then down through the connectors to the keys ans then back to the decoder.

Given that it is not all keys (notes) but only some don’t work it may be something common like the +3.3V power supply to only some of the resistors. As can be seen there are 3 x +3.3V power feeds that feed 4 resistors each for all the keys (notes). If one feed for example was missing then this would affect more notes than if only the one resistor was faulty as this may only affect say two notes over all the octaves. Alternatively the problem may be the connector at the decoder end of the circuit board.

Hopefully this all makes some sense to you. You said that you cleaned all the sockets so presumably this means the ones on the DMLCD board as well as the 61L and 61H boards.

Block Image

(click on image to enlarge for better viewing)

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

Hi @carloslope62584

On the DM control board there are 4 resistors used in the circuit for the D and G# notes.

They are:

wire 3 - multi resistor RA836 pins 5-6 10K Ohm and RA835 5-6 1K Ohm

wire 4 - multi resistor RA836 pins 7-8 10K Ohm and RA835 7-8 1K Ohm

See image below:

Block Image

(click on image)

Was dit antwoord nuttig?

Score 1

2 opmerkingen:

I tested the resistors and they show the correct ohms, the connector with CN831 is correct, I reinforced the solders but problem wasnt solved. All D and G# keys continue to fail. Rubbers are definitely not the problem either. Could it be the integrated chip?

door

@carloslope62584

Did you measure the +3.3V on pins 3 & 4 of CN831?

Did you prove continuity of the 2 wires all the way from cn831 to the D and G# keys and not just in and out of each connector?

door

Voeg een opmerking toe

Hello,

I had the same problem!!

All my C (except C1) and F# disapear...

Its the same problem as suggested..

But, i'm facing some trouble to mesure the resistor 837 ! with the multimeter i'm not receiving any values from any of the other resistors... i presume that the problem should me in this resistor, rigth? Or shoul I look to CPU?

(i did the path until the keys, and the flat wire, and its all okay.

best regards

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

I got a new adaptor and the problem disappeared.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

@dgx205

You need a DMM (digital multimeter) and set it to 20V DC and then connect the meter's black test lead to an earth point on the board (screwhead perhaps or bright metal chassis point) and the red test lead to either side of the resistor and check what voltage is shown.

Connecting it backwards would only shift the problem to other notes if you only reversed one end and the cable was faulty.

Was dit antwoord nuttig?

Score 0

3 opmerkingen:

I have the same problem but with the D and G# keys of all octaves. Could you please tell me what resistance I should test with the multimeter? I checked each of the connectors and they appear to be correct.

door

@carloslope62584

Please confirm the model number of the keyboard player?

door

Voeg een opmerking toe

Voeg je antwoord toe

sly5176 zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 8

Afgelopen 7 dagen: 26

Afgelopen 30 dagen: 91

Altijd: 15,882