Vind oplossingen voor je vragen over reparatie van je computer.

11392 Vragen Bekijk alle

Windows 7 Pro 64 will not run Windows Updates

I have not been able to update my windows for months, have turned off the service, cleared the cache and rebooted, still no go

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

Commentaar:

Didn't you hear that Windows 7 system is not longer supported by Microsoft? Even if you are getting some Updates it is wise to check them and not just alowed to install because they are there. Sometimes you can "screww up" situation even worse.

door

Windows 7 support ends on January 14, 2020 ;)

door

Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

3 Antwoorden

Gekozen oplossing

@guajiropa If you get no joy from the above fix try a SFC scan to see what errors there are in your .net framework .

To run the System File Checker tool, follow these steps:

Click Start, and then type cmd in the Start Search box.

Right-click cmd in the Programs list, and then click Run as administrator.

If you are prompted for an administrator password or confirmation, type your password or click Continue

At the command prompt, type the following line, sfc /scannow (note the space before the backslash) and then press ENTER

When the scan is complete, close the command prompt window, restart the computer and test to see whether the issue that you are experiencing is resolved.

You may also be prompted to insert a repair disc or install disk and run the repair program . In most instances this will fix your issue .

Have you updated past service pack 1? If not you may want to download service pack 1 and install it manually . Hope this helps

Was dit antwoord nuttig?

Score 3

Commentaar:

Yes, service pack 1 is installed

door

Did the problem start shortly after the update of sp1?

door

no, there were several updates after

door

did you run a sfc scannow? what results did you get ? Have you tried running a repair from a windows disc?

door

I ran it, it finished overnight, still unable to get any downloads with Windows Update, downloaded 205 updates using another command line option suggested, but the install hung on the first package for over 8 hours. I have located the package that it hung on and am thinking about installing that as a stand alone first and see where I am

door

Een opmerking toevoegen

I've come across this any number of times.

Unless you feel comfortable doing the following, I'd suggest you take it to your trusted technician.

Otherwise, follow the instructions below.

Go to wsusoffline.net and download the package. (currently version 10.8)

Unzip the package

Run wsusoffline\UpdateGenerator.exe (This will have to be a short path. It will work in your users download folder or the desktop folder, however if you archive downloads elsewhere like me, it might be troublesome. No fancy characters like !@#$% etc can be in the path)

If Security warning comes up advising it will make changes, accept it if your comfortable.

With the next dialog that comes up, It'll give you some choices. x86 or x64, do you know which you're running? You can find it in System Properties.

From here, its rather simple really.

Verify downloaded updates

Include C++ runtime libraries and .NET frameworks

Include Service Packs.

The following are optional, but are advised unless you have a really good malware/antivirus outside of what Microsoft offers.

Include Microsoft Security Essentials

Include Windows Defender definitions.

Thats it, hit 'start' and let it run til it tells you its done.

Once this is done, you'll need to MANUALLY run the next program.

wsusoffline\UpdateGenerator\client\UpdateInstaller.exe

You may need to login as 'admin' or or again approve changes made.

The next dialog box, 'WSUS Offline Update v# - Installer' gives you more choices. Mostly due to the previous step. Select the same choices as you did above (Don't worry, if you forget one you can just run it again and include it again later).

This will FORCEFULLY begin the script to install the packages you downloaded in the previous step with the updateGenerator.

This will LIKELY require several reboots and WONT likely reboot on its own. The DOS box (cmd.com or command.com) will tell you to reboot your computer.

Occasionally I get a customer whose needed or had a reinstall done and Windows refuses to update. Errors or just hangs forever looking. Its likely due to the update program simply not finding the server and needing its own update.

95% of the time, I just go with this as it updates everything along the way. Eventually, the automatic Windows Update program will figure out it will work and you can switch over to that.

Good luck!

Was dit antwoord nuttig?

Score 2

Commentaar:

Got an error verifying the downloaded updates :

. . . . . .

Thu 10/27/2016 0:11:07.03 - Info: Downloaded/validated most recent Windows Update catalog file

Thu 10/27/2016 0:11:07.04 - Warning: Deleted unsigned file "C:\Users\guajiropa\Downloads\wsusoffline108\wsusoffline\client\wsus\wsusscn2.cab"

Thu 10/27/2016 0:11:14.92 - Error: Catalog file ..\client\wsus\wsusscn2.cab signature verification failure

door

First step is elimination. Reduce the number of downloads you are doing.

There is also a thread on the WSUSOffline website about this matter.

http://forums.wsusoffline.net/viewtopic....

door

I put the folder on the root of C:\ and ran as admin, going along much further now . . . . . .

door

All day long, has been running this install :

Installing ..\w61-x64\glb\Windows6.1-KB2819745-x64-MultiPkg.msu...

door

Een opmerking toevoegen

Great job making it this far!

I think this is what i'd try.... Search for Windows 7 July Rollup

Download the x64 bit version.

Restart and immediately ***disconnect from the internet***

Install the July Rollup hopefully!

Profit!

Was dit antwoord nuttig?

Score 1

Commentaar:

Why do I need to disco from the internet?

door

not doubting you, just curious as to the reason

door

The only reason I can think of is to minimize. Occasionally (very seldom in my view) being connected to the internet is like having extra peripherals plugged into the computer while fixing an unrelated issue. There are many times this is suggested.

Kind of like unplugging a device in the middle of use...

door

If you start it with an active connection it will error out with a "Cannot connect to Server" error, run it while disco'ed and you get the Stand Alone installer, at least that is what happened to me

door

Een opmerking toevoegen

Voeg je antwoord toe

guajiropa zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 7

Afgelopen 30 Dagen: 31

Altijd: 1,234