The Mac Pro First Generation is an Intel Xeon-based workstation computer manufactured by Apple Inc. The first generation model includes the machines from 2006 through 2008.

301 Vragen Bekijk alle

Firmware update failed for MacPro 2006 1.1

Upgraded my system with 2 Xeon X5365 processors and they just work fine. After that I used the firmware upgrade tool for going from 1,1 to 1,2. That did not work. Any suggesstions why that's the case?

Does it influence the performance in any way when the firmware is not updated?

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 4


I also failed at using the Mac Pro 2006-2007 Firmware Tool. I click on Upgrade firware, it creates a ram disc, copies stuff and finally tells me to shut down the machine, start up holding the power button until the power led flashes or I hear a sound... then the Apple logo apperas along with a progress bar, for just a glimpse, then disappears and the machine boots into the primary OS... no upgrade, no progress bar progressing.

The firmware after that is still the 1,1 firmware and not 2,1 as it should be.


I also installed 2 x Xeon 5365 processors on my Mac Pro 1,1. It has 32GB of RAM.

When I click on the Firmware tool I get an error 5530, when it's trying to created the RAM Disk. I can not find what this error code means.

I've gone to a few youtube videos which show successful upgrades...

Any ideas?


Same 5365...Snow Leopard...32G RAM...error code 5530 thrown


It's you and me stickwithahit...seems like a dead thread but maybe we can get this going together.

This is driving me bat-$@$* crazy...are you running Lion on the Mac pro 1,1?

I think we have identical machines from a hardware standpoint.

I read somewhere that the update tool goes out on the web and downloads the EFI file from apple... apparently the link has changed so the tool won't work???

I downloaded the Mac Pro 1.2 EFI file's "supposed" to work if the .dmg file is on the dice so far.


Ah, well that is useful information... I can't find anyone who knows exactly what the 5530 error means, and Apple won't support machines this old...

I just order a second board from a shop on eBay (it was $25), so I'll try flashing that one, and if it fails, we know it is the internet part which is failing...

I have seen a board from the same people which is already flashed to 2,1... it's $50...

I'm reluctant to spend that much on this machine....

If I can't flash the motherboard, I think I may gut it and install a Hackintosh in the case, but I'm not at that point yet ;)


16 commentaren meer tonen

Een opmerking toevoegen

Gratis verzending van alle bestellingen van meer dan US$ 100 of met een Pro Tech Toolkit!

Doorblader onze winkel

3 Antwoorden

Gekozen oplossing

Your machine won't take it.

Pre-Installed MacOS: X 10.4.9 (8P4037) Maximum MacOS: X 10.7.5*

Mac Pro (8-core) MacPro2,1 MP21.007F.B06 (EFI 1.2) 1.15f3 (SMC 1.1)

Most firmware updates are automatically installed when you update or upgrade OS X. Some firmware updates are also available as downloads you can install manually. If your Mac needs a firmware update and it isn't installed automatically, check to see if a manual updater is listed below.

If you don't see a firmware version listed in this article, it means that either a firmware update is only available as an automatic update, or no firmware update is needed.

Was dit antwoord nuttig?

Score 3


Please see There is indeed a lot that can be done to the MacPro1,1 to have it run later versions of OS X. This is typed on a MacPro1,1 which happily runs 10.9.5 and 10.10; and as a result they are not limited to running only up to 10.7.5. I was delighted to discover that, and it's been a fun learning curve getting it to work. :-)

Also see the SFOTT project on



thanks guy.... ;)


DosDude has come up with a lot of firmware update paths since I first answered this.


Een opmerking toevoegen

I have used this firmware tool downloaded from netkas - Mac Pro 2006-2007 Firmware Tool page

My problem was that the serial number of my Mac Pro's motherboard was not listed in firmware tool patch.

The one I have added to this post is more updated and works well for my, if this firmware tool neither works for you try looking your motherboard serial number and modifying the patch in order to make it work.

Also you can follow this tutorial in order to update de SMC firmware!

I hope this post can help you!

Was dit antwoord nuttig?

Score 2


can you explain how to modify the patch?


This worked great! Thanks!


Een opmerking toevoegen

Hi, I’ve still not got the firmware upgrade to work. I’ve just picked up a second Mac Pro 1,1 motherboard, which I’m installing today. I’ll try to run the patcher on this one, and report back if it works or not. I wish you could doing this upgrade without having to be connected to the internet.

Was dit antwoord nuttig?

Score 0


I'm now running Pikify El Capitan...the installer successfully runs all the way through...I do the restart sequence, but it doesn't work. I could even get this far before...updates failed on Tiger, Snow Leopard, and Lion. I'm running WireCast 7 to capture 720p/30...all good.

I'm going to try the edited script method next week.


Een opmerking toevoegen

Voeg je antwoord toe

Rob Veenstra zal eeuwig dankbaar zijn.

Afgelopen 24 Uren: 35

Afgelopen 7 Dagen: 117

Afgelopen 30 Dagen: 556

Altijd: 5,193