Ga door naar hoofdinhoud

Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

518 Vragen Bekijk alle

MacBook Pro not booting after manual SMC update

Dear all,

To be synthetic:

I had kernel_task running over 300% with my HDD WD Blue

I replaced it with a SSD and the problem was still here...

I looked up into settings and found that i didn"t had the correct SMC and EFI version: see below:

Nom du modèle : MacBook Pro

Identifiant du modèle : MacBookPro8,1

Nom du processeur : Intel Core i5

Vitesse du processeur : 2,4 GHz

Nombre de processeurs : 1

Nombre total de cœurs : 2

Cache de niveau 2 (par cœur) : 256 Ko

Cache de niveau 3 : 3 Mo

Mémoire : 4 Go

Version de la ROM de démarrage : MBP81.0047.B2C

Version SMC (système) : 1.68f99

As you can see i dont have the correct SMC installed, and have an unknow EFI ... I dont know how i have the wrong SMC and EFI ..

I tried to install the correct SMC and EFI from el capitan but it said that i needed 10.9.5 version, so i moved on and downgraded to mavericks and when i tried to install i got a message that i can't upgrade the version ... (or it was not needed )

I tried to flash the SMC with rEFIt and it has succeed:

I used the 201MBP13.smc which is located on the .pkg of the MBP late 2011 update here:


Ofc i have a blackscreen so can't do anything..

Tried SMC, PRAM reset, nothing

Now when i'm booting, the fans starting at full speed 10 second after the boot, then turns about 6-7 seconds and then the mbp shut down ..

The mbp is out of waranty

Thanks for the help!

MacBook Pro, OS X Mavericks (10.9.5), 8,1 late 2011

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0





If anyone have any answer about that ^^


Een opmerking toevoegen

MacBook-reparatiesets voor batterijen

Vanaf $69.99

Buy Now

MacBook-reparatiesets voor batterijen

Vanaf $69.99

Buy Now

2 Antwoorden

Gekozen oplossing


Nothing worked for me, even the firmware restoration CD.

I manage to fix it: I had the 2010 SMC installed, so i took the smflasher.efi from the 2010 bundle, and the .smc from the 2011 bundle, then i flashed it with refit and it worked!


Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen
Het nuttigste antwoord

Dear Martel,

Firmware (including SMC and EFI) MUST be updated from AppStore, that's most stable version of SMC and EFI. And well, both are stored in MacBook's ROM. Don't worry first, you still have second chance because Apple Service Center has "Firmware Restoration CD" which able to repair almost all mac product's firmware


Athaariq Ardhiansyah

Was dit antwoord nuttig?

Score 1
Een opmerking toevoegen

Voeg je antwoord toe

Martel zal eeuwig dankbaar zijn.

Afgelopen 24 Uren: 1

Afgelopen 7 Dagen: 2

Afgelopen 30 Dagen: 19

Altijd: 1,751