Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie


Sixth iteration of Apple iPhone, announced on September 12, 2012. Repair of this device is similar to the previous models, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Black or White.

3418 Vragen Bekijk alle

iPhone not charging or recognizing cable/computer

I have my friends iPhone 5 that is not recognizing it is plugged in to power. Also itunes is not recognizing it on the computer. He recently replaced the battery (not from ifixit probably ebay). Can the battery itself cause the phone NOT to recognize that the phone is plugged in?

When I hit the power button, the flashing red battery is there with a lightning cord symbol on the bottom. Normally, when you plug it into a power source, the lightning symbol goes away and it just shows the battery. In this case, when plugged into a power source the lightning symbol is still there as if it doesn't recognize that it is plugged in. I used a wooden toothpick to pick out some lint in the port, and still nothing.

A few things I did was try using multiple known good OEM lightning charger cords and still no dice. I opened up the phone and disconnected, and reconnected the battery cable but no luck either.

Can a crappy battery cause the phone not to recognize the cord? OR is there a deeper issue here?


Block Image

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 1


So I got a new flex cable, overlaid it over the old one and plugged in the new flex

Cable into the board. Then plugged in a lightning charger, and same result, no charging and it doesn't sense something is plugged in, lightning cable symbol still there. I went ahead and replaced the cable anyways and same result. I did see a dent on a metal shield on the board where my friend could have pried on to get the battery cable off, but I'm not sure if that could have Been the cause of this issue. I have a picture attached. Can someone chime in on if the battery can cause this issue?[image|798063]


Ouch.. I wouldn't spend money on this device... unless I had free time and the ability to remove the shield and see what's wrong. Otherwise your phone seems dead, or could be bad U2, which is very tricky to replace on an iPhone 5. Not worth it in my humble opinion.


Voeg een opmerking toe

3 Antwoorden

Gekozen oplossing

@hoshi, like aqi said, first you must check that your charging dock is clean, not corroded.

Next step is to try a known good one instead. No need to replace it at this point, just overlay it the existing one and plug it instead of the old one and test with a known good cable and charger - or computer.

If the phone still doesn't connect via USB, you probably have a bad U2 chip. It is a controller chip responsible for USB communication and charging. It is a very common failure on iPhone 5.

If you want to be "extra sure," you can examine around the battery and dock connector to see if you see anything missing or damaged. Your friend could also have shorted something when disconnecting the old battery, if using a screwdriver for example to lift the battery connector. That would hardly be visible to the naked eye though.

You can also try installing a known good battery (not necessarily new) that is already holding a charge. If it depletes quickly and/or phone produces heat between the CPU and SIM card tray and/or still doesn't communicate with your computer and/or won't charge anymore once empty then for sure you have a defective U2 (google it) that requires micro soldering skills and tools to repair. Definitely not a DIY repair.

Was dit antwoord nuttig?

Score 5


I wish I have a spare charging port flex cable to use. If I can find one cheaply I may try that route and see. Thanks for the suggestions. I'll re-check tonight to see if I can see any visual damage/short and I will update later.


Voeg een opmerking toe

If you have cleaned the charging port- and still no luck than you have to change charging port full flex cable-

You can buy it on eBay

Was dit antwoord nuttig?

Score 1
Voeg een opmerking toe

My guess is that he probably accidentally unplugged the charging port connector from the logic board. Its immediately next to the battery's connector, I'd recommend opening it back up, unplugging the battery, unplugging the charge port connector, and then plugging them back in again starting with the charge port.

Was dit antwoord nuttig?

Score 0


Tried re-connecting the charge port and no luck. May have to invest in a new charge port flex cable.


Voeg een opmerking toe

Voeg je antwoord toe

Dao Yang zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 1

Afgelopen 7 dagen: 11

Afgelopen 30 dagen: 80

Altijd: 12,670