The De'Longhi EC155 is a Pump Espresso and Cappuccino maker.

14 Vragen Bekijk alle

Why is there no espresso coming out when the pump is on?

The machine is on and everything else is working fine, but when I turn the pump on, nothing comes out and I have no idea why.

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 1
Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

4 Antwoorden

Gekozen oplossing

If there is no espresso coming out of the machine, it is the result of either a lack of water in the reservoir, or a clogged pump. For the lack of water, simply refill the reservoir from any source of tap. To remove the reservoir, check out our easy to follow replacement guide. If the pump is clogged, descale the machine by using lemon juice. For instructions on how to descale the coffee-maker, check the user’s manual on page 10.

Was dit antwoord nuttig?

Score 1

Commentaar:

The pumps on these machines are completely plastic and thus not prone to clogging from scale buildup; scale only forms on metal surfaces. Furthermore, when descaling the machine a proper commercial descaling solution such as Dezcal or Durgol should be used; lemon juice or vinegar are sub-optimal solutions and can actually cause more problems then they solve. The very manual you linked states this clearly.

door

I am having the same problem! No coffee is coming out! However, this the first time I am

Using this. So I have no idea why it isn’t working.

door

Piston Gaskets O-Rings/Seals. Change them.

door

Een opmerking toevoegen
Het nuttigste antwoord

There are several things that can cause this. The most common is a clogged coffee basket; on this machine the basket can be disassembled for cleaning, do so and hold the metal screen up to a light to check for clogs. If the basket is clear, it's possible that your coffee is ground too fine, you're putting too much coffee in the basket or you're tamping too hard. It's also possible that the brew head screen has becomed clogged; you can remove this with a phillips head screwdriver and inspect it as you did the coffee basket screen. If you've done all of this and the issue persists then you probably having a failing pump; very common in this model as well as most other Delonghi semi-automatics.

Was dit antwoord nuttig?

Score 5

Commentaar:

If it is a failing pump, is that replaceable or worth replacing (cost & service of new pump)?

door

Een opmerking toevoegen

It can also be the issue of descaling.

I clean the filter, the boiler as indicated in the manual. But after 1 year (!gasp) the machine won't deliver expresso anymore.

I found that it is suggested to descale every 200 brews! So I descaled the machine and it's back, working.

Here's what I did.

Don't load any filter.

Take a container below the boiler.

Plug the machine.

Fill the water tank with 50% white vinegar and mix with 50% of tap water.

Turn the knob for the red light, wait for the OK green light and turn to the most right option (the one that you usually make espresso with)

Wait for hot water to drip, do this during the green lights for 1/4 of the water tank.

From time to time, turn the top frothing knob and let the descaler go through.

Repeat for another 3 times, and

then do the steps again with a second tank with 25% white vinegar and 75% tap water.

Finally, load a full tank of tap water to the tank. This is to wash off the descaler from steps mentioned above.

Load another tank of water if the acid smell continues.

Once done, unplug the plug. When the machine gets a bit cooler, unscrew the boiler and clean the boiler. Put it back.

Clean the frother as well.

That should be it. It took me about 2 hours. My machine was working as usual. Hope you have success too!

Was dit antwoord nuttig?

Score 1

Commentaar:

I had exactly the same problem, and followed the advice to de-scale (using 50% white vinegar solution) as you also suggested.

The result is a coffee machine working perfectly again!

I will now follow the instructions I ignored in the past - and clean and de-scale regularly :)

door

If the water is getting into the de Longhi coffee holder but not coming out and the holder's round metal mesh is clear then the spring-loaded little valve in the middle of the round black plastic mesh-holder may be stuck. Take the mesh off its black plastic base and push hard on the little dimple in the middle of the base. It should give - this is what lets the coffee out of the holder and maintains the pressure to give a good crema. Clean it and reassemble.

door

Thank you so much for this! I'd done everything, cleaned everything, de-scaled and just could not figure out why no water was coming out. I checked that little valve and now it's working again!

Many thanks!

door

Thank you Chris Darwin, releasing that spring has just saved me lots of cash.

door

Thank You, Chris Darwin, I appreciate your Insight. Though I have a question. Perhaps our model is a bit different. When I pushed hard on the center, nothing moved, tho I saw that I could unscrew the center. Behind it was the conical spring, it fell out. I ran the machine once without the spring, the de-scale solution came out! I thought it was fixed! Ran it again, nothing came out, as in the original problem; no coffee, but pump sounds. I put it all back together, still nothing. Could a pipe cleaner clean out whats further inside, where the spring came out of? Or anything else I'm missing? I appreciate any input! Thank You!

Mark

door

1 commentaar meer tonen

Een opmerking toevoegen

My machine is producing no water, even with an empty basket, and the machine is BRAND NEW! This is the first use. It has been properly preheated and I have followed the instructions to the “t.” The milk steamer works fine so there is no lack of water. The compressor rumbles away but no water comes out.

Was dit antwoord nuttig?

Score 0

Commentaar:

Have the same issue with my brand new ECOV 311 GR Icona Vintage. Some quantity of steam and water comes out of steamer during the preheting period. When I press the coffee/water button, only hot water from the steamer is produced while the filter remains perfectly dry (the steamer knob on the top is turned to minus). The steam button looks like it is working, but I still can't get the indicator light to go green - steamer produces steam almos immediately no matter how I turn the knob.

door

Een opmerking toevoegen

Voeg je antwoord toe

Thet Htike zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 108

Afgelopen 7 Dagen: 929

Afgelopen 30 Dagen: 4,068

Altijd: 48,040