Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

377 Vragen Bekijk alle

Why is my iMac display not powering?

After replacing my 2010 iMac HDD with a SSD my display isn't powering on. I had originally thought it was simply the display data cable (which I had damaged), but after replacing it with a new one it still isn't responding!

I can hook up an external display and everything else works great. The display preferences only recognize the external display so I think that rules out only a back light issue.

The first 3 of the 4 diagnostic LEDs are on. All the connectors and cables look fine.

Anyone have any ideas what is going on?

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 2
Voeg een opmerking toe

1 Antwoord

I'm in the same situation. I got a new display data cable from aliexpress but that hasn't solved it. Let me know if any solutions work for you and I'll do likewise.

Was dit antwoord nuttig?

Score 0

Commentaar:

Took my iMac to a repair place last week. He said that he isn't sure whats wrong 100% yet. They plunged in new screens replaces all the cables and other testing but could not get the lcd to power. He thinks the graphics cars is damaged partially.

After telling him what I had done and who the locking inde on the original cable wasn't working right he thinks that the computer powered on wile the cable was not fully inserted or crooked (or the data cable was damaged) and may have caused a short and damaged the card (apparently the power also follows though the cable making it easy to happen.)

He is taking the hole computer apart now to see if he can find a fix by taking a better look at the GPU (on the back side of the logic board). He has had some success repairing partial damaged GPUs in the past. I will try to keep you posted.

door

Keep us posted as I have the same problem. I changed the CPU. Then the iMac will not boot. Put back the original i3 CPU, still it does not go past the fans starting to blow. No chime, no light on the display. I wonder if booting up the iMac with the LVDS cable not seated could damage the GPU.

door

My mac repair guy concluded that the logic board was damaged. That somehow the display cable shorted out damaging the connector and nothing else. Everything else checked out as ok, including the GPU. :(

door

Thanks for the info. I did the EXACT same thing...it's interesting a new display didn't work, glad to rule that out...I found a logic board for $300 anyone know of one for less?

door

Thanks for the update. I can understand this because the LVDS cable is very difficult to insert back in the connector and I may have thought I had it in place but may have not been so it could shorten the logic board in some way. My problem is I have no external video, no startup chime, just the fans starting. Is it possible that the cable could have just damaged the logic board so that it simply will not boot at all? I have the LED lights lit no. 1 - 2 - 3. Even if I detach the video cable, the LED 3 lights. That should mean that the display is recognized. And shouldn't I even get a backlight?

door

5 commentaren meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

thesallad zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 2

Afgelopen 30 dagen: 3

Altijd: 580