Ga door naar hoofdinhoud

The second generation of Lenovo's Miix 8 inch tablet was released in October 2013. It is powered by a 1.8 GHz Intel Atom Z3740 Processor, 2 GB of RAM, 32, 64 or 128 GB of storage, 2x2 802.11a/n wireless, bluetooth 4.0, and optional WWAN in certain models.

5 Vragen Bekijk alle

Why does the touch screen stop working?

When using my tablet it stops registering my input. I click the screen and the tablet does not respond.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score 7
1 Opmerking

i also suffered from this problem for a very long time .. and i followed all the instructions on this page, however, it did not solve the problem .. until one day i simply noticed that the adapter i connected with the charger was such a cheap bad one .. so i tossed it and got a new better one .. and the problem was so solved and the tablet worked as good as new

ie: check if the problem is with the power connection.


Voeg een opmerking toe

5 Antwoorden

Gekozen oplossing

Hi Nicolas,

If your tablet screen is not responding anymore, it is usually the fault of power saving settings making your device sleep when you don't want it to.

The first (and easiest) thing to do is make sure your drivers are all up to date.

Visit Lenovo's support center and navigate to the appropriate touchscreen drivers for your device. You'll need to uninstall your old drivers, restart the tablet, and install the new drivers.

Alternatively, you can head over to Intel's Download Center and download the driver update utility. The utility will install the latest driver and then restart your device. After, navigate to Control Panel (found below the taskbar)>Power. Disable "Intel Display Power Saving Technology".

If you are using an external device or digitizer, and the tablet works otherwise, try disabling the power saving settings for the HID. Go to Control Panel>Device Manager>Human Interface Devices>I2C HID Device>Power Management Tab. You'll be looking for the setting labeled "Allow Windows to turn off this device to save power". There are I2C HID Device entries, so make sure to disable the setting on both.

If you tried both of those, or the tablet doesn't respond to your fingers, and are still having problems, you'll have to open your device. Pry open the back cover, unplug the MB and TS wires, and firmly plug them in again.

Hope that helps.

Happy fixing!

Was dit antwoord nuttig?

Score 7

3 opmerkingen:

unplugging and MB and TS wires worked for me, thanks


first and foremost clean your screen off with a damp cloth or paper towel...water only. i used a disinfecting wipe and it apparently coated the screen with something that made it touch insensitive after a minimal cleaning off of that residue it works perfectly again.... since it is so easy to do, try this first if you ever cleaned your screen with any chemical wipe.


I check the internet and notice this problem of HID and I2C is common with all tablets like Asus , Lenovo , HP etc. The hardware is different for all these brands and so is the BIOS program but if you notice there is one thing that is common in all these tabs and that is the Microsoft OS and its associated legacy drivers which link the tab hardware to the OS. I am now %#*@ sure this problem is actually with the OS and not with the hardware or the BIOS


Voeg een opmerking toe

I have the same problem constantly reoccurring and usually try any combination of the following:

1. Press the area around the top right (if landscape, bottom right if portrait) corner of the screen until I see my touch being registered by the touchscreen.

2. Uninstall the I2C HID (marked with “!” inside a triangle) and then “scan for hardware changes” – however, this requires a mouse to be connected.

3. Repeat No. 2 above, until I no longer see the exclamation mark sign.

4. Restart the machine

Most often, I use No. 2 then do No. 1 (in that sequence). Nowadays I carry a mouse with me all the time, since even midway through using the tablet the screen often freezes. Really, this often almost pushed me to the brink of selling this otherwise wonderful machine.

Was dit antwoord nuttig?

Score 6
Voeg een opmerking toe

Other than taking the back off, I have gotten the touch back by doing all the tricks above. I have had the touch come back just by plugging in a mouse. Now that I am on windows 10 I have had fewer issues.

A quick way to know if the issue is hardware or software is to power off the device, wait 5 seconds and then press and hold the volume up and power buttons at the same time until the Bios type screen is displayed. If the touch is responsive than its not hardware (this time).

Was dit antwoord nuttig?

Score 3

1 Opmerking:

Same issue here. Since Windows 10 this is a constant recurring issue. Indeed the bios check shows the touch-screen is still functional.


Voeg een opmerking toe

14 June 2017- reinstalled latest win 10 to solve it - nix. Tried pressing touchscreen - nix.

This advice from Adam (above) worked for me with the latest win 10: "A quick way to know if the issue is hardware or software is to power off the device, wait 5 seconds and then press and hold the volume up and power buttons at the same time until the Bios type screen is displayed. If the touch is responsive than its not hardware (this time)." - Thanks!!

I also came across this hardware solution on the Lenovo forum by mlindroo. It's already mentioned here but the photo is a great help:

"As pointed out in other forums, this very common problem is really only due to the graphics cable / chip being a bit loose.

0) Remove the micro SD memory card (if any)

1) open the unit by inserting e.g. an old plastic credit card on the opposite side of the mini USB port, then gradually work your way around to open the back cover.

2) Carefully remove the back cover, and gently press the display chip / cable located next to the USB port, see photo below (some users have installed a piece of soft tape [1 x 0.5cm] to apply constant pressure but I am not sure if it is necessary)

3) Reattach the back cover, and power on the unit again. "

Was dit antwoord nuttig?

Score 2

1 Opmerking:

This worked for me. All touch functionality back.


Voeg een opmerking toe

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Nicolas Jones zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 3

Afgelopen 7 dagen: 42

Afgelopen 30 dagen: 184

Altijd: 108,266