Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Onderdelen & Gereedschap

Released October 2008 / 2.4, 2.53, 2.66, 2.8 or 2.93 GHz Core 2 Duo Processor

481 Vragen Bekijk alle

Internal Seagate 1TB Hybrid boot drive not recognized

I'm trying to install a new hybrid drive in a Macbook's standard HDD bay. I formatted it on a Core i3 iMac, and installed Mavericks. It works fine externally (via USB) and will boot on the iMac. But the Macbook Pro (Core 2 Duo) does not recognize the boot partition, and just shows the folder [?] on startup.

There are two partitions on the drive (300GB and 700GB). Seagate says the SATA III is backwards compatible, but Mayer here suggested using a jumper to drop the transfer speed. I'm not sure how best to do that (can I just fashion a jumper from a paperclip?) or if it would work on this model.

Is it possible the Core 2 Duo will not support a drive this large? Thanks for any responses.

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

Commentaar:

UPDATE: I was able to startup the Macbook from this new drive externally) (using my iFixit USB adapter!). So it is not a compatibility issue, but a problem with the internal connection I would think.

The original hard drive had mechanical failure after being dropped. Could that have damaged the internal cable as well? Seems a remote possibility.

door

ADDITIONAL UPDATE:

- Installing a new HD cable did not solve the problem.

- An older HD (SATA I) worked fine when installed in the drive bay.

- Putting a jumper on the 2 leftmost pins of the 1TB Seagate drive did not solve problem.

I am reluctant to reformat the 1TB drive as a single partition, but that's the last possibility I can think of. I'll probably put it into an external case and get a smaller, slower drive for internal use.

door

SUCCESS AT LAST: Seagate drive working as intended. The SATA cable and connection are fine. Must conclude that the problem was in the drive itself, and the way it was initially formatted. Further comments below.

door

Happy to here it's working!

door

Voeg een opmerking toe

Nintendo Switch-kits

Een snelle oplossing die je weer mee laat doen

Koop Switchkits

Nintendo Switch-kits

Een snelle oplossing die je weer mee laat doen

Koop Switchkits

2 Antwoorden

Gekozen oplossing

How about checking the systems firmware, Apple did make some alterations that do effect Auto SATA speed sensing HD's. Follow this Apple TN on how to check and update: EFI and SMC firmware updates for Intel-based Macs

Was dit antwoord nuttig?

Score 2

Commentaar:

Thanks, Dan. The Boot ROM version appears to be up to date. But I downloaded the updater anyway, and tried to install it while booted from the external hybrid drive. I got a message saying "this software is not supported on your system." Mysterious....

door

A possible clue: I have a saved system profile with the original hard drive date. Under SATA/SATA Express data it says the disk S.M.A.R.T. status is "verified." The current system profile, with the new drive external under Storage lists the S.M.A.R.T status as "not supported." Is that significant?

door

OK, good to hear the firmware is OK, The reason you can't see the SMART is the I/O is not native SATA (USB or FireWire accessed)

door

The only thing left is the SATA cable is bad. FYI - Your system can support much larger HD so thats not the issue.

door

You're right, I'm afraid. I found another thread on the topic (Internal hard drive disk not recognized) and even tried the masking tape trick suggested within, but no luck. Hoping Apple will offer a replacement...

door

1 commentaar meer tonen

Voeg een opmerking toe

I have to un-accept this answer, I'm afraid. I installed a new HD cable, but am still having the problem. The question now (based on what I've read here and elsewhere) is:

Do I need to jumper the drive to run at 3.0Gb? Or, should I reformat the drive as one partition?

Opinions welcome!

The firmware is up to date, the Mac will support 1TB and the SATA drives are supposed to be downwards compatible. Theis one is SATA III 6 .0GB (Seagate model 1000LM014) with 2 partitions (300Gb and 700 GB). When running it externally via USB, both partitions mount and I get these system reports:

Hardware Overview:

Model Name: MacBook Pro

Model Identifier: MacBookPro5,1

Processor Name: Intel Core 2 Duo

Processor Speed: 2.53 GHz

Number of Processors: 1

Total Number of Cores: 2

L2 Cache: 6 MB

Memory: 4 GB

Bus Speed: 1.07 GHz

Boot ROM Version: MBP51.007E.B06

SMC Version (system): 1.33f8

Serial Number (system): W88480021GN

Hardware UUID: 26BA7B20-2AC2-530F-98AD-C3DEA148B0F4

SATA/SATA Express:

NVidia MCP79 AHCI:

Vendor: NVidia

Product: MCP79 AHCI

Link Speed: 3 Gigabit

Description: AHCI Version 1.20 Supported

Storage:

Galehead:

Available: 105.72 GB (105,719,644,160 bytes)

Capacity: 299.49 GB (299,489,112,064 bytes)

Mount Point: /

File System: Journaled HFS+

Writable: Yes

Ignore Ownership: No

BSD Name: disk0s2

Volume UUID: 087BFEBE-D55F-3F14-8850-CA815D191E6A

Physical Drive:

Media Name: ST1000LM 014-1EJ164 Media

Protocol: USB

Internal: No

Partition Map Type: GPT (GUID Partition Table)

S.M.A.R.T. Status: Not Supported

Was dit antwoord nuttig?

Score 0

Commentaar:

Did you inspect the cable connector on the logic board to see if it is damaged. You'll likely need a magnifying glass to see things. Something just isn't adding up here. Known working drive, replaced SATA cable; Only thing left is damaged logic board connector or a drive thats firmware is out of date.

door

I checked the Seagate site for firmware downloads - they don't list one for this model (ST1000LM014). I bought the drive bare (out-of-box) so perhaps it had been used. An older drive (SATA I) works fine with this cable and logic board, though.

Thanks for paying attention, Dan. I am going to try to get to the bottom of this and report back.

door

To recap (as best I can recall): the 1TB drive came in OEM packaging. I connected it to an iMac via USB, with an iFixit adapter, formatted it with 2 partitions using Disk Utility, and transferred my data using Time Machine.

After the problems described above, I bought a 320GB SATAII drive and an Inland USB external enclosure. Formatted that drive using the iMac and new enclosure, had no trouble running it inside Macbook. Then put the 1TB drive in the new enclosure w/o jumper, and connected it to Macbook. Disk Utility told me it only had a 128GB Master Book Partition! Using it with the iFixit USB adapter, I could see the GUID partitions, which was baffling. So I put it back into the Inland enclosure, and used the Macbook to completely reformat it and reinstall the OS. And that finally did the trick - it would start up Macbook internally. Somehow the hybrid 1TB drive had a boot partition that survived 2 attempts at reformatting.

door

Voeg een opmerking toe

Voeg je antwoord toe

Jen Morris zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 1

Afgelopen 30 dagen: 11

Altijd: 2,374