Ga door naar hoofdinhoud

Released July 12, 2002. Identified by model number K45SSWH.

33 Vragen Bekijk alle

Why won't my mixer turn on?

I have my KitchenAid Classic Mixer plugged into the wall and when I turn it on to any of the speeds nothing happens. I've tried to unplug it and plug it back in but I cannot get it to turn on!

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 10
Voeg een opmerking toe

3 Antwoorden

Het nuttigste antwoord

If your mixer isn't turning on, there could be several issues with it. First, check the circuit breaker in your home to make sure power is supplied to the mixer. Unplug your mixer and wait 15 seconds to plug it back in. If this does not work, there could be an issue with your phase board. See the guide on how to replace the KitchenAid mixer phase board.

Was dit antwoord nuttig?

Score 3

2 opmerkingen:

My mixer was squealing so I disassembled it. It was working fine other than making noise. I found metal shavings and a loose screw. I cleaned shavings, tightened the loose screw, lubricated and reassembled. Figuring this may be the fix to the noise. I plugged back in, turned it on and nothing. Power from outlet in working. When I turn on, it doesn't make any noise at all, like it's not getting power. I looked at electrical area and all connections seem fine.

door

Thank you Chris for help I really appreciate it

door

Voeg een opmerking toe

My issues were that it 1st - only ran on one speed, then 2nd, wouldn't turn on at all. The problem (I think) ended up being two loose bolts in the back housing behind the switch controller. When I took off the back cover, they just fell out. I couldn't find any photos of what the assembly should have looked like, so it was trial and error testing. Once I put the loose bolts back on the “hidden” posts/screws on the far back metal plate and tightened them down (and undid all the other adjustments I tried to make first) it worked like a champ.

Was dit antwoord nuttig?

Score 1

1 Opmerking:

I had the same problem but that didn’t resolve my issue

door

Voeg een opmerking toe

Applies to models that tilt and that have a circuit breaker: Upon accessing the breaker from the underside of the stand, I found the white wire disconnected. Apparently the wire was under tension when the user tilted the head upward, until it finally broke. I reattached it, but used solder and heat-shrink tubing to insert an extra thumb-length of wire to prevent tension when tilted. Now it works perfectly.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Chris Gonzales zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 uren: 6

Afgelopen 7 dagen: 19

Afgelopen 30 dagen: 64

Altijd: 9,150