Ga door naar hoofdinhoud

1.83, 2, or 2.16 GHz Core Duo processor

349 Vragen Bekijk alle

Airport Extreme 802.11n card

I purchased an Airport Extreme 802.11n card and tools from iFixit and installed according to your instructions.

Didn't work. System Profiler said it was not connected. However when I checked it. it was connected.

What am I doing wrong?

Thanks

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Een opmerking toevoegen

MacBook-reparatiesets voor batterijen

Vanaf $69.99

Buy Now

MacBook-reparatiesets voor batterijen

Vanaf $69.99

Buy Now

1 Antwoord

Gekozen oplossing

If the card is new

and indeed connected (in the slot squarely and firmly) then the connector board or the logic board is a fault.

You did not say what caused you to purchase a new wireless card... if it was loss of wireless functionality then that could have been the problem all along. In which case you need a new logic board.

Update

before you send that card back, there is a software app. from Apple that you need to enable N networking (if it wasn't OEM) if that's the issue.

If this answer is acceptable please return and mark it.

Good Luck,

N.

Was dit antwoord nuttig?

Score 1

Commentaar:

When I try AirPort_Extreme_802.11n_Enabler I get error msg. saying it don't have correct hardware (tried it again with n card installed - same result).

Appears that this card won't work with my A1150 MacBook Pro. I'm returning it.

door

Thanks for your response.

I assume the card is new (I bought it from the iFixit repair instructions page).

My original card still works (I put it back in when the new one didn't work). I was replacing the hard drive for a larger one and taking out my Superdrive to clean the lens and I thought I'd try to improve my Airport performance.

I put the old Airport card back to verify that the connections and antennae were not at fault. Then I put the new card in again for another try. This time Profiler saw it but I could not turn Airport on. I created a new Airport in Network Preferences, repaired disk permissions, reset SMC and the other thing, and PRAM, spun around 3 times counterclockwise, sacrificed a goat, and restarted.

Still didn't work so I put the old one back in and it works as it always did - and now I'm happy it works at all. So I guess in a way the new card helped.

door

Please move this to UPDATE the powers that be have decided it's not good form to answer your own questions.

door

Een opmerking toevoegen

Voeg je antwoord toe

jiwataki zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 0

Afgelopen 30 Dagen: 0

Altijd: 2,300