Ga door naar hoofdinhoud

The PowerBook G4 was initially announced at Steve Jobs' keynote at MacWorld Expo in January 2001. Its body was made mainly of Titanium and had a 15" screen.

173 Vragen Bekijk alle

Cannot connect to wireless network

I just recently picked up a couple of Titanium G4s, one Onyx and one DVI. Both were not working and thanks as always to your pages I got them both going. I bought a couple of PCI Airport cards for them and I'm getting the same problem from both machines irrespective of which card is in which machine. The cards can be seen by the systems, both have 9.52 showing in the Firmware info but neither card can see networks that are available. When I put in the network details thru Internet Connect I get the same message whichever card or laptop combination.

'There was an error joining the Airport network 'virginmedia*******'

All my other Airports join Virgin broadband but this is the oldest machine I have tried to do it with, is that significant?



Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Een opmerking toevoegen

PC Laptop batterijen

Een snelle fix voor een grote boost.

Nu winkelen

PC Laptop batterijen

Een snelle fix voor een grote boost.

Nu winkelen

1 Antwoord

Gekozen oplossing

Apple had a firmware update for these boards. Here's the link to the AirPort updates AirPort downloads. There was also a paid update to give you 802.11n depending on the Airport board.

You could also try altering your AP so 802.11a (802.11g) connections are possible.

Lets us know what happens

Was dit antwoord nuttig?

Score 3


Thanks for the message Dan.

I tried the downloads but everything connected with Airport related to Base Stations and I don't use an Airport Base Station. My home wireless signal is provided by my Virgin Broadband Router. What I thought I needed was something to alter the way my Airport card works, however I've taken the Powerbook out and about and I've discovered that it will pick up open networks. I took it to MacDonalds (where else) and there the WiFi is provided by O2. Access is by way of a code that is sent by SMS. I had no problem getting connected. The problem seems to be when WPA2 security is used on the network because wherever I try to use the PB on open networks there is no problem but I cannot connect to WPA2 networks.

Any ideas?


Sadly, you don't have WPA or WPA2 services within Snow Leopard and with the AirPort card your system has. That was a newer standard that requires both a hardware & OS update to gain.


Een opmerking toevoegen

Voeg je antwoord toe

Peter Benson zal eeuwig dankbaar zijn.

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 6

Afgelopen 30 Dagen: 41

Altijd: 4,280