7.9 inch display iPad Mini, with 16, 32, or 64 GB of storage.

695 Vragen Bekijk alle

Ipad Mini Black Screen After Digitizer Repair

Hello everyone,

I recently cracked my Ipad Mini (Black) glass digitizer. I bough a new digitizer from eTech:

http://www.etechparts.com/Glass-Digitize...

I then heated up the sides and lifted off the screen with spudgers. (I have done this many times with ipad 2's, without any problems) Then I was following a ifixit guide to all of this which did not say to disconnect the battery. So I replaced the digitizer and I thought all was well. I dd not seal it yet though. I then tried to turn it on and saw a dim apple logo and a x near the bottom. I followed a ifix it guide to do the correct soldering. Now when I turn on the ipad I see nothing. But if I hold the home button it says

"siri is not currently available, please connect to the internet" At this point I dont know what to do, please Help!

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0
Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

3 Antwoorden

Gekozen oplossing

"I followed a ifix it guide to do the correct soldering."

What? There better not be an iFixit guide that advises you to put a blob of solder in your mini in an attempt to short across a very replaceable filter.

This is an extremely common problem in the iPad mini, and there a dozens of people out there who can replace the backlight fuse for you. Find one and send it to them if hard reset does not solve and the fuse is actually blown.

jessa

Was dit antwoord nuttig?

Score 1
Een opmerking toevoegen

The ifixit guide does tell you to disconnect battery.

If showing up dim images looks like you've blowen the back light

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

This exact same thing happened to me, probably as a result of the ipad inadvertently turning back on as I was removing the broken screen.

Hold the power button and the home button in at the same time for the 10-15 seconds required for a hard reboot. Mine worked just fine after that.

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

Aaron zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 0

Afgelopen 30 Dagen: 1

Altijd: 379