Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Onderdelen & Gereedschap

Sixth iteration of Apple iPhone, announced on September 12, 2012. Repair of this device is similar to the previous models, requiring screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Black or White.

3401 Vragen Bekijk alle

iPhone 5 won't boot after disassembly, is my iPhone a paperweight now?

So here's the pre-story: my mom's iPhone 5 has been having problems with the sleep/power button. It wouldn't work at all. So, figuring there might be dirt, etc. causing the problem, I pulled it apart following a guide.

I cleaned everything out, made sure I was being very careful, using all the proper tools (utilizing my brand new iFixit Pro Tech Toolkit), etc. I got everything back together, then powered the iPhone on.

The good news: the power button worked!

The (very) bad news: about 5 seconds into the boot process (showing the Apple logo), the screen dims and some text appears, as if it were booting in verbose mode. Here's the text:

[NAND] _FindFlashMediaAndKeepout:601 physical nand block offset 1

[NAND] start:356 this 0xa3148400 PROVIDER=0xa16f5e80 flashMedia=0xa16f5e80

[NAND] WMR_Start:149 Apple PPN NAND Driver, Read/Write

[NAND] WMR_Start:174 FIL_Init [OK]

[NAND] WMR_Open:371 VFL_Open [OK]

[NAND] s_cxt_boot:88 sftl: error, unclean shutdown; adopted 697 spans

[NAND] WMR_Open:420 FTL_Open [OK]

[NAND] _publishServices:642 FTL capabilities: 0x0000001

[NAND] _ppnvflGetStruct:3469 Checking borrowed blocks - count: 23 max_count: 23

[NAND] _fetchBorrowedList:881 number of borrowed blocks 16

Please help! I really hope this is fixable. From my (minimally educated) look at what I wrote above, it seems like the problem is either the unclean shutdown or physical memory. *panicking* Thank you in advance for your help!!!

Beantwoord deze vraag Dit probleem heb ik ook

Is dit een goede vraag?

Score 9


Update: found Tyler Farrar's fix over NANDJ_ Find flash media and keep out ERROR FIX!, pulled off the front facing camera connector, now she boots like a charm. I'm going to dig around some more and get back to everyone.


Alright, got everything fixed, for the most part! Thank you everyone for the help! :)


So how did you end up fixing it?


Laurens, he's telling us that it was a flex problem as predicted (read my answer below). Start by isolating which flex is causing the problem by taking them all off except power and adding back one by one.


The best way to repair your troubles is opening over your iPhone,and remove your battery connection for few seconds wait a little bit and reconnect your battery and your screen afterwards and Voila!! you should be all set...Any questions my name is Barri.


1 commentaar meer tonen

Voeg een opmerking toe

Nintendo Switch-kits

Een snelle oplossing die je weer mee laat doen

Koop Switchkits

Nintendo Switch-kits

Een snelle oplossing die je weer mee laat doen

Koop Switchkits

2 Antwoorden

Het nuttigste antwoord

NAND errors like that usually look worse than they are. Most commonly they are caused by one of the flexes. If you go back in and make sure each flex is properly seated, and make sure they don't have any traces of finger oils you will likely solve the problem. If this still doesn't work, then you can isolate which flex is causing the error by taking everything off and (starting with power flex) add them back one by one.

Or you could be unlucky like me and find that your first NAND error was in fact a damaged NAND chip :(

Was dit antwoord nuttig?

Score 3
Voeg een opmerking toe

How to fix..teach me pls me no understand...? Thankz

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Voeg je antwoord toe

Christian zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 2

Afgelopen 30 dagen: 2

Altijd: 22,461