Ga door naar hoofdinhoud

Model A1138 / 1440x960 screen resolution

85 Vragen Bekijk alle

G4 PowerBook won't boot

I'm posting this question because I have some specific symptoms that aren't mentioned in any other post I've looked at.

I suspect the hard drive has gone bad. There is a repetitive clicking sound, and the PB will not boot past the gray screen. Don't even get the Apple logo in the middle. I have tried booting from a USB external drive that has my superdooper back up, but I only get the curly and straight arrow in the display. Nothing else ever appears. I don't know if it's necessary to have a firewire drive for booting purposes, and that may be why it won't boot off the USB drive.

It will not boot off an authentic Leopard install disc. In fact, it took me a couple hours to get the thing to eject. The PB has always been a little finicky with recognizing discs. It sometimes would take a few tries to get it to read DVD's, etc.

I would proceed directly to getting a replacement hard drive, but I'm not entirely sure that will solve the problem.

I've tried it in Target mode, but the attached Mac sees nothing. I suspect it's looking for the PB's HD and it's toast.

It may be that I need a new optical drive and hard drive. Appreciate any help sorting this out.

Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score -1
1 Opmerking

Were you using a Firewire cable in Target mode?


Voeg een opmerking toe

3 Antwoorden

Gekozen oplossing

The PowerBooks require FireWire connections for external HD's that are bootable not USB connection. In addition, Target mode likewise needs to be connected via FireWire to the other system (USB connections won''t work). Let us know if you had tried a FireWire connection in either case.

As to your optical drive it may just be some dust on the lens. Try a CD/DVD head cleaner which has a micro brush. It should clean the lens and allow you to boot up with the recovery CD the system came with. You could have an issue with the Leopard DVD as the optical drive on this system did not handle dual layer disks (Apple sold a CD version as well as a DVD version).

Was dit antwoord nuttig?

Score 2
Voeg een opmerking toe

I only tried a USB external boot drive. Tried FireWire to another Mac for target mode, but it would not see the drive....obviously because I think it's hosed. I had originally put a Snow Leopard disc in and the PB read it fine. So I think the leopard disc would/should work, as I believe that's the way I upgraded from tiger. I hope the optical is ok. I think my next step is to find an IDE drive.

Was dit antwoord nuttig?

Score 0

5 opmerkingen:

Oops, I left an answer instead of a comment toy reply.


You did see the Target mode screen icon on your PowerBook when you put it into Target mode. If you did then yes your drive is toast and you'll need to find a PATA (IDE) drive to replace it.


Don't forget to clean the other systems optical drive. If cleaning doesn't fix it you might as well replace it too. Maybe a little cheaper getting both parts at the same time for the same source if its possible.


I did *not* see the target mode image on the PB's screen. I can only hope the bad drive has prevented normal operation of things like that. I have another drive on order. I will also have to locate a cleaner for the optical.


If the Target Mode Icon did not show up on the systems screen you didn't get it into target mode. This function is part of the systems BIOS services and still would work on a system that doesn't have a working HD.


Voeg een opmerking toe

Your HD is definitely dead -- a repeating clicking sound is a definite sign of a failing drive.

Often these early laptops will not going into target mode if they do not have a volume to offer in target mode, so if there is a bad HD and there is a bad optical drive or there is not a presentable disk in the optical drive, the laptop has no volume it can put in target mode, and therefore often won't do it. Some laptops will still go into target mode regardless, and some won't...I don't recall how the various PowerBooks behave, and anyway there are several models of 1.67GHZ, so we don't have enough info to know anyway. The other thing that will prevent target mode is a firmware password.

The way to rule out both these situations is to power on holding down the option key. If you see an option menu, you don't have a firmware password (in which case you would see a padlock instead). A visible option menu also means it's unlikely you have a board, GPU, or video cabling issue (which is a concern if you never see anything but a white screen).

Personally, I have never in my life seen a laser lense cleaner restore a flaky optical drive to functionality, so I wouldn't spend money on that.

Was dit antwoord nuttig?

Score 0

1 Opmerking:

A good CD/DVD cleaner (w/micro brush) has saved me a few times on these older drives. Many newer drives have a cleaner or a lens cover.


Voeg een opmerking toe

Voeg je antwoord toe

Tony zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 4

Afgelopen 30 dagen: 6

Altijd: 1,509