Model A1311 / Late 2009 / 3.06 or 3.33 GHz Core 2 Duo processor

249 Vragen Bekijk alle

Boots up with a black screen

When i boot up my iMac the screen stays black the hard drive is running, makes beeping sound but, screen stays black.

I hooked the iMac to a plasma TV and it worked with no trouble. What is wrong?

This i mac is Model A1311 mid 2010 21.5"

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 3
Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

4 Antwoorden

Gekozen oplossing

Sounds like your display is having problems. Can you shine a flashlight at an angle at the display and see the faint image of your desktop and icons? If you do that would imply the backlight has died. Either the CFL's or the power inverter has gone. If you don't see the image then you likely have a bad LCD or the LVDS cable has become loose.

Was dit antwoord nuttig?

Score 3

Commentaar:

Hi Dan i changed the lcd for a new one still the same black screen with no image. The new screen came with new cables which i used.

door

Are you able to see a faint image on the display at all?

door

No image on the display dan

door

Bummer! You'll need to open it up to check your cable and locate the diagnostic LEDS to see what they tell you. You'll find them just to the right of the memory slots, and sit behind the SATA cable where it comes out of the connector. LED 3 is the important one here.

LED 1 Indicates that trickle voltage from the power supply has been detected. This LED will be ON when the computer is turned off and your power supply is working correctly.

LED 2 Indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED 3 Indicates that the computer and the LCD display are communicating. This LED will be ON when the computer is turned on and video signal is being generated.

LED 4 Lights only if the computer detects an over-temperature condition. This LED will be OFF when the computer is turned on and running at the correct temperature.

door

Hi Dan i checked the LEDS All the LEDS worked as they should, but when i turned the computer off after the test. ( after 20 sec LED 1 turned off.)

door

3 commentaren meer tonen

Een opmerking toevoegen

Hi guys, did this problem get resolved at all? I'm having the same issue at the moment... all 3 LED's working as they should, but no image at all... please help!

Was dit antwoord nuttig?

Score 0

Commentaar:

Are you able to see your desktop via an external display?

door

Thanks for getting back to me, Dan! I have a thunderbolt to HDMI but even in normal circumstances I would have to go in to the system preferences in order to select the thunderbolt in the display options... it doesn't just share automatically as soon as the cable is hooked to the TV. So, as I can't see the screen I won't be able to do so! :( Unless there's a different method!

door

Can you get your hands on a Mini DisplayPort to VGA adapter? And you'll need a VGA display (your TV may offer it as an input option).

Most HDMI sets do send the needed active signal which should enable the system to see the display and automatically enable it. Try altering the input options within the TV to see if that triggers things once you come back to the correct port. Also some adapters may have an issue.

door

Een opmerking toevoegen

Still having this problem, only my backlight turns on after like 5-10 minutes of waiting so it is not completely broken. Anyone have any idea of how to fix this problem?

Was dit antwoord nuttig?

Score 0

Commentaar:

Also curious if anyone else has had success. I have the same issue.

door

Een opmerking toevoegen

I have got the same problem but with my late 2009 iMac emc 2308.

External monitor works without any trouble.

All 3 LEDs are working!

The backlight works, but no image is displayed.

Do you have any ideas what I can try next?

Was dit antwoord nuttig?

Score 0

Commentaar:

Did you get anywhere with this? I have the same issue - backlight is OK, but there is no picture.

If I try another LCD panel it works fine, so the problem is NOT the logicboard, the inverter board, or the LVDS cable, but is something with the LCD panel itself. But does that even have any serviceable parts?

door

Een opmerking toevoegen

Voeg je antwoord toe

john v zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 13

Afgelopen 7 Dagen: 83

Afgelopen 30 Dagen: 354

Altijd: 20,219