Ga door naar hoofdinhoud

The fourth Google Nexus smartphone, released November 13, 2012.

75 Vragen Bekijk alle

How to locate sensors(gyroscope/proximity etc)

Hello Sir,

I have a Nexus 4 which has out of nowhere started having unusual issues. Suddenly few of the sensors (not all) stopped working. Specially the gyroscope(for auto-rotate) and proximity sensor doesn't work that I know off. Otherwise audio,light etc seems to work.

First of all I thought its some compatibility issue with 4.2.2 update and tried every software repair solution that I can get but no avail. I also tried everything like a game,youtube etc to check if gyroscope works in anything but no.

Seems like there is something wrong in the hardware. I purchased it from a guy(not from google), and it seems like he has opened it once or twice, evident from marks on side. There are no proficient repair shop nearby I live who are ready to make an attempt to find the issue and repair it, so I am forced to do it myself. I have the tools to open it up but don't know where exactly to look for sensors and how to check if its working.

I'd be really grateful if you can shed some light on this matter and help me.



Beantwoord! Bekijk het antwoord Dit probleem heb ik ook

Is dit een goede vraag?

Score -1
1 Opmerking

devendra lavaniya, you should find most of the IC's step 17 and 18 on here Nexus 4 Teardown


Voeg een opmerking toe

2 Antwoorden

Gekozen oplossing

Thanks all for the input ..

Finally I got it repaired the only way I knew, by swapping out the mainboard.. actually the technician told me that there was some water damage which caused hardware to malfunction. Cost me 120$ and I have sold it now.

Was dit antwoord nuttig?

Score 0
Voeg een opmerking toe

Hi there. Did you use the OTA update sent to you, or was this a root and flash job? There are known baseband compatability issues, and you may be a victim of that. The first thing I would do is flash it back to stock using these instructions Flash Stock ROM if you haven't tried that already.

Was dit antwoord nuttig?

Score 0

6 opmerkingen:

Yes mate .. I have flashed the 4.2.2 OTA image but I did it systematically and flashed everything system,data,bootloader,radio,recovery ... As the phone was already on 4.2.2 when I got it , OTA were not coming so I tried this.

Additionally I have downloaded apps that read sensor's responses like 'AndroSensor' and they don't detect any readings with any of these sensors.

The phone has never been in a major drop that can cause the h/w to break. And I can confirm it was working fine before.

How should I proceed now ?


If it's not software, then it's gotta be hardware. The sensors are IC's on the logic board as indicated by oldturkey03, which I personally wouldn't attempt to replace by hand. The next logical and probably expensive step would be to replace the logic board.


Yes.. that is the answer I anticipated. However I'm stumped on one little query. If these two sensors are at totally different location on the IC, how is it possible that they broke at once and nothing else is hampered.

I'm still holding onto believing that its still something that can be solved with software. Will returning back completely to original 4.2.1 help ?

If yes, can you guide whre I'll find its image ?


That's exactly what I was thinking when I asked if you have reverted back to stock. The version you will be seeking out is 4.1.2. I'm looking for it, but so far, I've only come up with JDQ39 Occam image. I get a strong feeling that there is a compatibility issue with the version of the image you are using. I'll keep looking for a stock 4.1.2 image, and I'll link to it when I do. Good luck!


Hey mate,

After good research and checking with local repair shops I have found the probable cause of the issue. I'm not very techie so don't know all details but I was told that this happens when the calibration settings stored in emmc chip of the logicboard gets altered somehow and all/some sensors stop working.

The solution to this as suggested is a logic board swap. Just swap logic board with other Nexus 4 , start and setup once and then swap back.

Is this could be the real problem and a viable solution to the problem? have you guys come across somthing like that ?


1 commentaar meer tonen

Voeg een opmerking toe

Voeg je antwoord toe

devendra lavaniya zal eeuwig dankbaar zijn.

Afgelopen 24 uren: 0

Afgelopen 7 dagen: 0

Afgelopen 30 dagen: 0

Altijd: 7,128