If the power button flashes on when depressed, but nothing else...

POWER MAC G4 MDD 867MHz DP

If the power button flashes when depressed, but nothing happens... is this a power supply issue, a cable issue, or a logic board issue, or power switch/board issue?

Still awaiting input to my followup. Thanks

9/18/10 -- Forgot to update this. The PSU was dead. Replaced it for $40 and donated to a school. Cheers.

Beantwoord! View the answer Dit probleem heb ik ook

Is dit een goede vraag?

Score 0

Commentaar:

How many flashes? ralph

door

Een opmerking toevoegen
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12
Verspreid de kerstsfeer
Krijg 12€ korting op je aankoop van 50€ of meer met de code FIXMAS12

5 Antwoorden

Gekozen oplossing

No answer unfortunately...have another thread going. I have the same problem. I replaced the power supply. If I hold the start down continuously, it stays lit, but nothing happens. I removed all the cards except video and RAM in one slot. If I hold down the start button, it stays lit, but nothing happens. I assume its a bad motherboard or CPU? How do you remove the CPU from the motherboard?

Was dit antwoord nuttig?

Score 0

Commentaar:

Hey Peter -

I'm happy to post an answer for you on this one, if there isn't one present already. Please post your question about CPU removal in a G4 MDD. Thanks!

Jason

door

Hi Peter - Not sure if you ever solved your MDD problems, but I spent roughly 20 months to find a replacement PSU for my MDD (with the same exact symptoms) that was under $40. Well, I finally got one. I just wasn't willing to dump anything into this unit since the machine itself is only worth roughly $220-250 in perfect condition.

Your best bet... set a saved search on ebay for this PSU and wait for the price that you think is reasonable. Oh, and make sure you're matching up the appropriate PSU to your unit. I went with the 400W (instead of the lowered 360W which was an effort to reduce noise) because I have a number of things pulling off wattage from this unit. It runs great now, and will soon be posted on craigslist.

Cheers

door

Een opmerking toevoegen
Het nuttigste antwoord

This can be any number of things. If I had it in my shop the first thing I would do is replace the 3.6 volt lithium pram battery on this machine. They can be had at Radio Shack. Try that and let me know if it worked and we'll go from there.

Was dit antwoord nuttig?

Score 2

Commentaar:

see below :) thanks

door

Een opmerking toevoegen

you could try resetting the pmu. Hold the power button down, and see if the light flashes on and off rapidly. Unfortunately, these are signs of a bad power supply. you may also want to check your ram, graphics card, and any other expansion cards.(Remove, then reinstall them)

Was dit antwoord nuttig?

Score 1

Commentaar:

hi all -

completed the following w/ known good parts: replaced the lithium battery, front switch, graphics card, memory, and removed all expansion cards. I had swapped out lithium internal battery first (before coming here). Also left it unplugged and disassembled for the day...

end result: no change. the button on lights up briefly once. no flashing or any indication of booting up. Thanks

Jason

door

Een opmerking toevoegen

To remove the CPU, take off the heat sink which is held down by 4 screws. Lift the card up with your fingertips from the edge of the card closer to the back of the case. When the card is at about a 45 degree angle relative to the plane of the main logic board it will come out of the black plastic holder. Slide the black plastic holder off of the posts. Disconnect all cables, take out the video card, remove the 1 screw that is holding down the board and take out the board.

Was dit antwoord nuttig?

Score 1
Een opmerking toevoegen

Much later than other answers here but I had a similar problem. Replaced battery as suggested, no luck. Finally found another power supply and replaced it - still no luck. BUT I found elsewhere on here there's a tiny PMU reset switch on the board which can be pressed (and held for 5 seconds) now all is well! That's probably all my problem was. The battery was not expensive, was 7 years old so no loss there but the power supply was not cheap! At least, I think I now have a spare.

Was dit antwoord nuttig?

Score 0
Een opmerking toevoegen

Voeg je antwoord toe

jcarter zal eeuwig dankbaar zijn.
Weergavestatistieken:

Afgelopen 24 Uren: 0

Afgelopen 7 Dagen: 2

Afgelopen 30 Dagen: 7

Altijd: 4,395