Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

Help

Deze versie is geschreven door: Josh ,

Titel:

Can a Magsafe i/o Board charge a battery externally?

Tekst:

I'm trying to narrow down the power problem that I'm having with my Macbook Pro. I received a dead Early 2008 15" Macbook Pro for free and I'm trying to bring it back to life. When I connect my Magsafe charger, I don't get any light on the charger. I have two Magsafe chargers available to me (both 85 watts, one "T" shaped and one "L" shaped). Neither charger works with this MBP. Both chargers work perfectly with my 2010 MBP.

The symptoms seem to indicate a bad Magsafe i/o board in the computer. So I ordered a new one (made sure it was the correct one) and I installed it yesterday. Nothing has changed. I still get no light on my Magsafe charger and the computer still won't turn on.

So I guess I'm looking for some information on how to trace this power issue. If the Magsafe board is good, shouldn't it still charge the battery even if the Logic Board is bad? The internal battery cable goes right from the Magsafe i/o board to the battery and doesn't involve the logic board. Logically it looks like the battery should at least charge even if the Logic Board is bad.

So I'm wondering if I'm missing something or if maybe I did something incorrectly. So I'm looking for any information that someone can provide about how power gets routed to the system so that I can try to narrow down where it's going wrong. Any thoughts on this issue would be appreciated.

Apparaat:

MacBook Pro

Status:

open

Goedgekeurd antwoord:

72420

Origineel bericht door: Josh ,

Titel:

Can a Magsafe i/o Board charge a battery externally?

Tekst:

I'm trying to narrow down the power problem that I'm having with my Macbook Pro. I received a dead Early 2008 15" Macbook Pro for free and I'm trying to bring it back to life. When I connect my Magsafe charger, I don't get any light on the charger. I have two Magsafe chargers available to me (both 85 watts, one "T" shaped and one "L" shaped). Neither charger works with this MBP. Both chargers work perfectly with my 2010 MBP.

The symptoms seem to indicate a bad Magsafe i/o board in the computer. So I ordered a new one (made sure it was the correct one) and I installed it yesterday. Nothing has changed. I still get no light on my Magsafe charger and the computer still won't turn on.

So I guess I'm looking for some information on how to trace this power issue. If the Magsafe board is good, shouldn't it still charge the battery even if the Logic Board is bad? The internal battery cable goes right from the Magsafe i/o board to the battery and doesn't involve the logic board. Logically it looks like the battery should at least charge even if the Logic Board is bad.

So I'm wondering if I'm missing something or if maybe I did something incorrectly. So I'm looking for any information that someone can provide about how power gets routed to the system so that I can try to narrow down where it's going wrong. Any thoughts on this issue would be appreciated.

Apparaat:

MacBook Pro

Status:

open