Ga door naar hoofdinhoud
Help

Deze versie is geschreven door: Justin Ogihara (stem details) ,

Titel:

Charge loop, only charges when turned on

Tekst:

So here’s a challenging and strange problem:

The phone will not charge when turned OFF. When plugging in the charger, the Android logo appears briefly and then (before switching to the charging indication) the phone crashes only to start again and crash again (i.e. charging loop).

I have ruled out the following causes:

* Battery (replaced)
* Charging port (replaced three times)
* Connection between charging port and main board (looks clean and intact, the phone charges when turned on)
* Charging source (both via computer and normal charger)

The computer claims “USB device not recognized”.

Upon replacing the battery, the phone continues to behave this way. However, the new battery being pre-charged I was able to start the phone normally. When plugging in a charger once the phone is turned on, the phone charges without problem.

I started observing the charging loop shortly (but not immediately) after my phone fell while charging. Still I am inclined to think this is an issue with the software (maybe the kernel since this is before booting the OS) because a hardware problem would not discriminate between the phone being turned on or off (right?).

Any hints, ideas or theories as to what might be the cause of this issue are greatly appreciated!

Some stats:

Moto G3 XT1541

Rooted and running Lineage (14.1-20190220-NIGHTLY-osprey) since about 1.5 years

Android 7.1.2

Apparaat:

Motorola Moto G 3rd Generation

Status:

deletedopen
deletedopen

Bewerkt door: Thomas ,

Titel:

Charge loop, only charges when turned on

Tekst:

So here’s a challenging and strange problem:

The phone will not charge when turned OFF. When plugging in the charger, the Android logo appears briefly and then (before switching to the charging indication) the phone crashes only to start again and crash again (i.e. charging loop).

I have ruled out the following causes:

* Battery (replaced)
* Charging port (replaced three times)
* Connection between charging port and main board (looks clean and intact, the phone charges when turned on)
* Charging source (both via computer and normal charger)

The computer claims “USB device not recognized”.

Upon replacing the battery, the phone continues to behave this way. However, the new battery being pre-charged I was able to start the phone normally. When plugging in a charger once the phone is turned on, the phone charges without problem.

I started observing the charging loop shortly (but not immediately) after my phone fell while charging. Still I am inclined to think this is an issue with the software (maybe the kernel since this is before booting the OS) because a hardware problem would not discriminate between the phone being turned on or off (right?).

Any hints, ideas or theories as to what might be the cause of this issue are greatly appreciated!

Some stats:

Moto G3 XT1541

Rooted and running Lineage (14.1-20190220-NIGHTLY-osprey) since about 1.5 years

Android 7.1.2

Apparaat:

Motorola Moto G 3rd Generation

Status:

opendeleted
opendeleted

Origineel bericht door: Thomas ,

Titel:

Charge loop, only charges when turned on

Tekst:

So here’s a challenging and strange problem:

The phone will not charge when turned OFF. When plugging in the charger, the Android logo appears briefly and then (before switching to the charging indication) the phone crashes only to start again and crash again (i.e. charging loop).

I have ruled out the following causes:

* Battery (replaced)
* Charging port (replaced three times)
* Connection between charging port and main board (looks clean and intact, the phone charges when turned on)
* Charging source (both via computer and normal charger)

The computer claims “USB device not recognized”.

Upon replacing the battery, the phone continues to behave this way. However, the new battery being pre-charged I was able to start the phone normally. When plugging in a charger once the phone is turned on, the phone charges without problem.

I started observing the charging loop shortly (but not immediately) after my phone fell while charging. Still I am inclined to think this is an issue with the software (maybe the kernel since this is before booting the OS) because a hardware problem would not discriminate between the phone being turned on or off (right?).

Any hints, ideas or theories as to what might be the cause of this issue are greatly appreciated!

Some stats:

Moto G3 XT1541

Rooted and running Lineage (14.1-20190220-NIGHTLY-osprey) since about 1.5 years

Android 7.1.2

Apparaat:

Motorola Moto G 3rd Generation

Status:

open